SOLVED: Theme Style > Typography in 1.8 beta shows wrong greyed-out default value, inheriting from mobile

Continuing the discussion from NO BUG / DUPLICATE: Carousel element seems to be mobile-first, not inheriting desktop settings:

I reported an issue at the link above in a comment to another issue I thought was related. It was dismissed as being related to a mobile-first test I ran at the breakpoints. However today I restored from a backup only to find the issue remains even though it was well before I ever tested mobile-first breakpoints. I then went as far as installing v1.8 beta on a fresh install (was 1.7.3 prior), and immediately had the same issue I reported in the comment linked above, so this seems to be an issue in 1.8 beta, nothing to do with the mobile-first test I ran earlier.


The greyed out text inherits from the mobile value but not desktop. Despite the greyed out value showing from mobile instead of desktop, it actually uses the desktop value still, so this is just a wrong default greyed-out value is all. I can tell this because if I manually enter ‘95%’ it will shrink in size, but if I use ‘105%’ it remains the exact same from desktop without changing.

Steps to reproduce:

  1. Install 1.8 beta on top of 1.7.3.

  2. Edit page and go to Theme Styles > Typography.

  3. Set desktop breakpoint html root font-size to something like 105%.

  4. Set mobile breakpoint html root font-size to something like 95% (ultimately just a different value than step 3 above).

  5. Now go to tablet breakpoint and you’ll find the greyed out value takes from the mobile breakpoint even though the value actually being used is still the desktop one (as it should be).

Kindly fix this in the final 1.8 release :slight_smile: If you need access to my staging site for debugging purposes (assuming this is for some reason not reproducible for you), let me know and I can recreate the user account for you. Thank you for your time.

Desktop: 105%

Tablet (notice the greyed out value shows what I’ve set on mobile, but the actual value used / rendered in the editor is still the desktop value:

Mobile: 95%

Hi Dustin,
Thank you for creating a separate report for this.

I was able to reproduce the issue and added it to our bug tracker.

Best regards,

1 Like

Just wanted to add that this affects not only the HTML font-size setting but the same goes for the Body size too and presumably the Headings.

At Desktop for Body font size:

Not set on any other breakpoints, greyed out body font-size value in mobile shows 15px (the default size in Bricks) even though it’s actually using 16px (100% HTML and 1rem body size) which I can see because if I actually type 15px it becomes smaller text:

Eager to see this fixed in the final release of 1.8.

It looks like this didn’t make it into 1.8 beta 3. Hopefully this will come in the final release. Is that the goal, or would this be fixed in a later version instead?

Hi Dustin,
Probably in a later version.

Hopefully this can make it into the next release. :slight_smile: I know it’s perhaps minor but it’s a very annoying defect, throws me off often as I can no longer trust the greyed out value in the boxes and need to reorient myself to understand what the real value used is versus what’s displayed. :melting_face:

I see this is still an issue. Any ETA on when this will be resolved? It may seem like a minor issue but it has a rather large impact when designing a site since it’s giving completely incorrect values if a different value for it is set on a lower breakpoint, which as I’m sure you know incorrect values will lead to bad decisions / solutions for designers.

Hi Dustin,
We rarely, if ever, mention ETAs. If it were an easy problem, it would already be solved. Sometimes things are more complicated than they seem.

Yes I assumed this was perhaps a complicated one being that it isn’t resolved yet (never said it was “easy”), was just hoping for an update as it had been over a month since the last one, and like I said it’s a rather impactful bug even if it may seem like more of a minor one at first read. Hopefully this will be resolved soon. :crossed_fingers: I can offer up a cloned staging site if you need another one to test in too.

Would love an update on this one, if it’s been identified and should be resolved soon or if it’s still not narrowed down yet. If there’s anything I can do to assist (staging site access for example) please don’t hesitate to ask. This is an incredibly annoying bug. :frowning:

Hoping this can be addressed soon please, this is a very irritating defect when working on new site builds since it’s displaying incorrect inherited values.

Related issue reporting today… when typing in a value for padding for example, and then clearing it out, it will show the entered value instead of the actual default or inherited value. For example, when entering a value of “10” when the default if “12”, and when deleting the “10” text still shows the greyed out value as “10” instead of “12”.

These prolonged issues with the greyed out values are honestly incredibly frustrating, highly impacting on new site builds, and needs to be prioritized higher. These values basically can’t be trusted at all as they’re too often showing the wrong greyed out value, and makes designing new sites troublesome. @Thomas - hate to tag you here, but is this a defect we can prioritize fixing please?

@charaf or @aslotta - is it possible to get an update on this defect please? It’s an incredibly irritating defect when building new sites as the placeholder values are incorrect, and surprising it seems to have been an issue reported back in February too by @macksix in a related post here: WIP: Height & Width for Form fields shows lower breakpoint placeholder for higher breakpoints.

I’d appreciate any kind of update you can provide on this whether it’s an ETA or if there’s anything I can do to help you in solving the issue (if you need access to a staging site, happy to provide it again). Thank you kindly in advance. :slight_smile:

Hi Dustin,
We’ve fixed this issue in Bricks 1.9.6, now available as a one-click update in your WordPress Dashboard.

Changelog: Bricks 1.9.6 Changelog – Bricks

Please let us know if you are still experiencing issues.

Best regards,

1 Like

Can confirm, this bug is finally solved. Thank you.

It seems there’s a new defect though that’s related to some degree… linking it here for convenience: Theme Style > Typography in 1.9.6 shows wrong placeholder value in body font size and empty values in h1 heading font size