SOLVED: Bricks classes lost

My work all are gone and my sites are looking like garbage now, please can we recover it? I worked so many library and it just lost :frowning:

Kevin, how did you fix this?? Could it restored?

1 Like

I lost my classes today on 1.6.2.
Is there a backup solution for "undefined "classes?

Screenshot 2023-01-31 at 19.08.45

Can this be marked as unsolved? This is still an issue - still the main reason I can’t start using bricks as it’s too risky.


Try doing this and reaching out to zestjosh. He might be able to help.

so now obviously 1.6.2 still losing classes. i really hope bricks team will get back to this critical problem asap and at least give an answer about. silence is not a really good sign i have to admit.


I created few projects in the last few months in the other page builder, just because I do not dare start any serious work in Bricks until this absolutely critical issue is resolved. Which isn’t, even in latest update obviously…

1 Like

I’ve done three pages in Bricks now and never noticed this problem, so I don’t know what it’s due to. What I do know is that I NEVER use the browser navigation (forward/back) when working with the Bricks editor, maybe this is a clue.
But I am encountering another problem that may be related. I am working in the Edge browser (on Ubuntu). I have it set up that Edge saves all open tabs when I close and reloads the entire session when I open it. I work on multiple tabs at the same time, but never have the same page/post open in edit mode on two tabs, always different ones, though many at the same time. The problem I’ve noticed is that when I open Edge and load the session, those tabs where the Bricks edit is have an outdated code, I don’t know how much older, or a previous save or even further back. But I learned that when I open Edge I ALWAYS have to press F5 on the tabs with editing to refresh the content, then everything goes back to the current state.

1 Like

Hi guys,
This thread is related to this fix mentioned in the changelog:

We are currently working on another “lost classes” bug that is different from this one. The result might be the same, but the cause is different.

If your classes are gone after using the prev/back button of the browser, please see Thomas’s post and provide the required information. As far as I can see, no one did this after the 1.6.2 release:

If your classes are gone after…
Please provide as much information as possible and please try to reproduce the issue again, to provide us with reproducible steps, as @macksix and @aslotta did in this thread, which helped a lot in debugging the issue.

The sooner we have a reproducible way, the sooner we can solve these serious problems.

Best regards,

@grafikundso I have removed the last 5 posts because they don’t help us one bit in this case.

If you have something concrete to contribute to the topic, we’d all be happy to hear from you. If not, I ask you not to be a troll. Nobody likes trolls.

Should you not be able or willing to comply with my request, I will be forced to close this thread, which will not help anyone.

Thank you for your understanding and have a nice weekend!


It does it now and then I think mainly it’s is because I use wacom tablet
Hope in the future they can change this so we do not have to scroll down to much
It get’s all very narrow

Hello Timmse I am not a troll we were just discussing the problem when you use a wacom tablet sometimes you cannot scroll down on the left in the page builder.
Cheers mate and enjoying Bricks :slight_smile:

@zestjosh I am facing the same issue with my site, i followed the steps and here is the URL Unserialize - PHP, JSON, Base64

Thanks for helping

Here you go!

Thank you for the swift response, how do i use this?

Just replace the option_value for the bricks_global_classes key in your options table with the input on the link I sent :+1:

1 Like

IT WORKED!!! Thank you VERY much bro. I am so much grateful.

1 Like

There’s supposed to be some tweaks in 1.7 to address this. If you’re on 1.7 and this ever happens again you should probably contact the Bricks team directly. I think they’re really trying to get to the bottom of this.

Nevermind, I see that you did it and they were not able to help in this circumstance. Glad jestjosh’s trick is still working!

1 Like

Hey there,
I have one issue and want to raport.
I lost all classes.
I finish single post template, and want to add one more thing. Then I add assigned sidebar to that template and start messing with widgets in gutenberg. I just want one widget- tags. And after I added it I start messing with styling, but nothing advanced, all in frontend gutenberg, and save that, all in Gutenberg. I was not satisfied and I delete that sidebar from template.
Then I start Archive template and saw that header and footer are not styled. And I then saw that all styling is gone, all classes are gone.
I trigger just one more thing between, tags condition feom BricksEsxtras but nothing to do with it and I then turn that off.

One more thing to mention, after all this I try to add saved section from structezy and it apply ok to the page. But when I try to add homepage, also saved, nothing apply.
Maxime from advanced themer jump in and try to help and discover this from screenshot.

Hi Emir,
Thanks for your separate report - let’s continue the discussion there please: WAIT: Lost classes in Bricks