SOLVED: Bricks classes lost

Bricks Version: 1.5.1
Browser: Chrome
OS: macOS
URL: local

I created custom classes for some elements to make styling quicker - ie card, pricing table etc. These have all dropped out of the page but I’m unsure why. The class drop down is empty now and so it has no memory of them in the system.


Hi Chelsea,
Thanks so much for your report!

What version are you using (please adjust your post accordingly) and what was the last thing you did before the classes disappeared?

Best regards,

Hi there

Apologies, I’ve updated that now. Using the most recent update on Chrome on my mac.

I was editing the footer template - then came upstairs and plugged into my monitor, then all of a sudden the styles were gone. For a while I thought it was perhaps not picking up my custom css then I realised all the classes had disappeared.

I’ve re-added them now and exported in case it happens again, but no idea what I could have done to cause that.

Hmm… so far, we don’t have another report on this, which would normally be the case since it’s a big problem.

I suggest you keep an eye on this, and if you find a way for me to reproduce the problem, feel free to get in touch!

Best regards,


The same has happened to me!!

I am working on a minor change on an existing site built with Bricks. I was making a change on a Template and after saving it, all the CSS classes I set when I was creating the site have disappeared. From every page. From anywhere!

I’ve managed to solved it, re-creating all the classes. But I have no idea what has caused it!

The elements that had custom CSS classes, have lost them all and an .undefined class has appeared. I also use Automatic CSS utility classes and all have gone.

Hope you can investigate on that because it’s been a pain in the ass to recreate one by one all the classes in each element, and in each page!

Thank you!!


Hey Knut,
Which version did this happen?

Hi Timmse,

Version 1.5.3

Can you provide me with the template and tell me what the minor change was so I can possibly reproduce the problem?


I can give you admin access to a copy of the website after being all the CSS classes re-created.
Also, I can tell you which template I was editing.

What is a proper and secure way to give you the password?

Via email to help@bricksbuilder :slight_smile:
Please include a link to this thread and tell us which template you were editing, so we can check it in detail.

Hi timmse!
Email sent!! :slight_smile:

Hey just wanted to leave a note here. this is happening to me quite a bit. Me and another dev have had this happen about 4-5 times in the past week and happened to Kevin geary in his newest youtube video Utility Classes vs Custom Classes: How to Build Maintainable Websites Like a Pro - YouTube at the 20 min mark. Newest bricks 1.5.4

Seems to happen when the page is saved and you go back in it is gone.


Hey Nicholas,
I watched the situation from Kevin’s video at 0.25x speed (which is extremely funny) and followed the exact same steps, but still can’t reproduce the problem.

I don’t know how to move forward with this…

yeah this is going to be a tough bug to catch. It seems to happen randomly and I cant seem to replicate the exact reason it happens. My other dev was working in bricks and switching to codebox and that seemed to happen a lot when he was in there. Seems similar with kevin but I cant speak for everyone else in this thread.


What happened to Kevin on that tutorial and what @sleeplesskxng seems to explain is not exactly what happened to me, but maybe it comes from the same issue.

In my case, all the classes created, in every element and in every page, disappeared (with apparently no reason). Then, in each element where there should be a custom class, there only was an .undefined class.

That broke the site completely, and the only way I managed to solve it was going through every page and re-adding each class. After adding a class that existed there before, all the properties of that class were applied properly. It is not that the classes were completely erased, just that they were unassigned to the element they were assigned before “the issue” occurred.

Hope it helps investigate this bug because it’s a huge one! It happened to me on a live client site that was already finished. I was required to make just a small text change on a template and… BAM! :fearful:


Hi Mustafa,
Welcome to the forum.

Your issue is completely different because your classes are still there :slight_smile:

Would you be so kind as to send temporary login credentials and a link to this thread to using the email address you used during the purchase?

Best regards,

same issue today.

I have made a minor change in a page and all my classes are disappeared !

it happened during the last revision a few minutes before the scheduled launch time of the site! it was a tragedy. We are still rebuilding all classes one by one :sob:
(Restarting from the backup meant losing all content changes made “on the fly” with the client, which would have been much worse)

(Bricks Version: 1.5.7 - Litespeed - Metabox AIO)

1 Like

Hey Lapo,
Sorry to hear this, but we still need a way to reproduce the problem. Especially when reproducing the bug reports, I make a lot of minor changes, but so far I have not encountered this problem once. Otherwise, we would have had a starting point long ago…

Hi @timmse , thanks for your reply!
I understand the need for more precise indications, but I honestly don’t know how to reproduce the exact problem as I was making numerous changes at the same time and only at the end, in the frontend, did I notice the problem.
Surely (following what was indicated by another user in another post of this forum) I have used the “undo” function several times (even if I had used it other times in the past both on this site and on others without problems… it seems occur randomly). I don’t know if this will help you.

Bricks 1.6-beta2

This might help.

See video: Recording #37

This is with the logo button set to open up the preview of the page.

  1. Add a custom class to 3 divs.
  2. Click the logo button for preview.
  3. Use the Browser’s Back Button to return to builder.

The custom classes are now missing!

The classes are still in the page though. If we manually hit save, the classes are still in the file, nothing is changed.

However, if we add an element and click save, we effectively deleted the custom classes.