SOLVED: Bricks classes lost

I just lost all my custom classes as well! I did have the preview mode window open. Trying to retrieve the classes in revisions does not help. Is there any way to retrieve them?


@m910 I helped someone with this issue the other day so I might be able to help you get the classes back.

Could you go into your wp_options table and search for the option_key “bricks_global_classes” and paste the option_value onto Then click the unserialize button and post the url here.


I am also surprised that there is no feedback from the Bricks team for such a long time and though it’s an extremely urgent and important issue. But I’m even more surprised that Bricks team doesn’t just start to roughly narrow down the reason(s) by simply asking us users and trying to identify patterns that way. Oxygen for example did a survey in their Facebook group to find the reasons why the builder has been loading so slowly.

Concerning the loss of classes, these (and a ton of other similar questions) could be asked to narrow down the reasons:

  • On which hosting environments were the websites running where class loss occurred (exact info needed for detailed analysis)?
  • Which actions have been performed inside/outside the Bricks Editor before the class loss?
  • Is displaying dynamic data enabled/disabled in the builder?
  • What has the DOM size of pages been which have been worked before the class loss?
  • Which plugins are installed?
  • … and several other similar questions …

Can common culprits (or group of culprits) be identified based on analysis of above given answers?


We are running into this issue constantly on NGINX on one specific site.

We create a page all with custom classes on elements. The original author of the page can close the builder and re-open it and the classes are still there. As soon as a separate user edits the page, all classes either disappear or become “.undefined”.

Very frustrating.


Oh … sorry to hear that. From my point of view solving this huge issue is the most important one at the moment Bricks team should work on!

No one wants to lose work. This is the first real killer criteria! If they don’t solve this VERY soon I doubt that Bricks will be used for serious work by serious agencies or devs‘

Come on by Bricks team, it’s about time to officially get in contact with us users to solve this issue in common anytime soon!

1 Like

Big thanks to everyone for the additional details & reports in regard to this issue. Especially the videos :ok_hand:

We could finally reproduce the “browser back button” issue that wiped out the custom classes for @macksix and @aslotta, and the global class @digitalgravy added in his video above around the 20min mark.

After adjusting the Cache-Control HTTP header inside the builder, the issue no longer occurs for us locally. We’ll ship this fix in 1.6.2 in a few days (performing a few more tests in the meantime).

If anyone still encounters this issue in 1.6.2+ please reply to this post incl. a screenshot that shows your Response Headers inside the builder (as illustrated in the following screenshot).

Please also mention if you are referring to the loss of your global classes (the ones you can access via the dropdown) or the CSS classes under “STYLE > CSS > CSS classes”.


Hi @thomas,

great to hear. Thanks for your update on this important issue.

I am experiencing another issue which could also be related to class loss for a few people. Please let me explain.

I do have a woo site and on my product single I am using tons of ACF fields (approx. 70/80 … didn’t count them). Often when saving (not every time, but very often), the save icon is
(1) either spinning and spinning forever (until I hit the save button a second time)
(2) or lasts about 1 - 2 minutes to finish the saving procedure

If (2) happens, my own managed hosting server, where all client websites are located, is being completely overloaded for this 1 - 2 minutes and no website on this server can be accessed or worked with both in frontend and backend. I am getting all greens in Bricks system info though and I am using a GOOD german server from a well known german hosting company (Mittwald). Even all cron jobs on OTHER projects are interrupted during this saving process. I have also been experiencing this on another site before with smaller cpt and acf templates , but couldn’t assign Bricks saving behavior as the culprit. Now I know that it’s reproducible behavior. And I am quite sure that it’s not a hosting server, cause I have built even larger templates with Oxygen too where this has never happened.

Why could this be (potentially) important concerning this class loss issue (no technician here, only guessing):
(a) If the save-icon/save-procedure is taking looooooong, I can well imagine, that (some) users are not patient enough to wait until the saving procedure has fully ended and are e.g. leaving the site, are continuing working on the site without edits being really saved.
(b) It seems that Bricks (?sometimes?) needs heavy server resources (when saving). Maybe this could be an issue on the server side too …
(c) Maybe this could also be this culprit for the editor lag … as I said: just guessing. Funny enough I am not experiencing this huge server lag (a bit yes, but not really a big problem. I am just reloading Bricks and editor lag is gone for a while. Running a Mac Pro here, if it’s important).

If you want to analyze this reproducible behavior I can create a staging site for you … we can also do a short screen sharing if you like …

Best Regards

Hi @beziehungsweise, i had a similar issue when using CPT’s on Bricks and tracked the issue on my Dev VPS via NetData and my finding was that the issue may be related to one of the experimental options in settings>builder>render dynamic data text on canvas.

Once this was deactivated the issue was resolved although I have noticed, in general, Bricks is resource heavy on servers, especially processor utilisation in comparison to other page builders and Gutenberg. Server spec is a Vultr HF 2 core (Intel Skylake) with 2Gb of RAM, OLS stack. Should be more than capable of running a WP dev site with no traffic. Hope this may be of some help.

1 Like

Hi guys,
We’ve fixed this issue in Bricks 1.6.2, now available as a one-click update within your WordPress Dashboard.

Please let us know if you are still experiencing issues.

Best regards,


My work all are gone and my sites are looking like garbage now, please can we recover it? I worked so many library and it just lost :frowning:

Kevin, how did you fix this?? Could it restored?

1 Like

I lost my classes today on 1.6.2.
Is there a backup solution for "undefined "classes?

Screenshot 2023-01-31 at 19.08.45

Can this be marked as unsolved? This is still an issue - still the main reason I can’t start using bricks as it’s too risky.


Try doing this and reaching out to zestjosh. He might be able to help.

so now obviously 1.6.2 still losing classes. i really hope bricks team will get back to this critical problem asap and at least give an answer about. silence is not a really good sign i have to admit.


I created few projects in the last few months in the other page builder, just because I do not dare start any serious work in Bricks until this absolutely critical issue is resolved. Which isn’t, even in latest update obviously…

1 Like

I’ve done three pages in Bricks now and never noticed this problem, so I don’t know what it’s due to. What I do know is that I NEVER use the browser navigation (forward/back) when working with the Bricks editor, maybe this is a clue.
But I am encountering another problem that may be related. I am working in the Edge browser (on Ubuntu). I have it set up that Edge saves all open tabs when I close and reloads the entire session when I open it. I work on multiple tabs at the same time, but never have the same page/post open in edit mode on two tabs, always different ones, though many at the same time. The problem I’ve noticed is that when I open Edge and load the session, those tabs where the Bricks edit is have an outdated code, I don’t know how much older, or a previous save or even further back. But I learned that when I open Edge I ALWAYS have to press F5 on the tabs with editing to refresh the content, then everything goes back to the current state.

1 Like

Hi guys,
This thread is related to this fix mentioned in the changelog:

We are currently working on another “lost classes” bug that is different from this one. The result might be the same, but the cause is different.

If your classes are gone after using the prev/back button of the browser, please see Thomas’s post and provide the required information. As far as I can see, no one did this after the 1.6.2 release:

If your classes are gone after…
Please provide as much information as possible and please try to reproduce the issue again, to provide us with reproducible steps, as @macksix and @aslotta did in this thread, which helped a lot in debugging the issue.

The sooner we have a reproducible way, the sooner we can solve these serious problems.

Best regards,

@grafikundso I have removed the last 5 posts because they don’t help us one bit in this case.

If you have something concrete to contribute to the topic, we’d all be happy to hear from you. If not, I ask you not to be a troll. Nobody likes trolls.

Should you not be able or willing to comply with my request, I will be forced to close this thread, which will not help anyone.

Thank you for your understanding and have a nice weekend!


It does it now and then I think mainly it’s is because I use wacom tablet
Hope in the future they can change this so we do not have to scroll down to much
It get’s all very narrow