NO BUG: MetaBox CPT hierarchical children Invalid Post Type

Bricks Version: 1.6.2

Cannot edit children of MetaBox CPT’s - gives Invalid post type Error

Steps to Replicate:

  1. Use Meta Box to add a CPT
  2. Add a post and check you are able to edit using Bricks
  3. Add a post and set as child to first CPT post
  4. Try to edit child post in Bricks
  5. Get Invalid post type error

Hi Dan,
Thanks so much for your report!

I haven’t tried to replicate the issue yet, but have you re-saved your permalinks after adding the CPT?
That might solve the “invalid post type” error. Please let me know if it helps, otherwise I’ll investigate deeper.

Best regards,

yes i have tried re-saving permalinks and also cleared cache too.

Spun up a brand new site last night and the issue still persists. For me anyhow

I followed your steps and created a CPT “Artists”, re-saved the permalinks, and can edit child posts as usual as you can see:

  1. Do you have any custom code or other plugins installed that might influence the permalink behavior?
  2. Can you provide us with login credentials (please send them + a link to this thread to using the email address from purchasing Bricks)?

Best regards,

Hmm, interesting.

I tried this on 3 different sites and did not work on any of them, even after saving permalinks.

Let me spin up some new sites and test some more over the weekend

Hey Dan,
Any news on the issue?

I have spun up a couple of new sites and not getting this error. There is 1 site that is still causing problems but i suspect it is something with a plugin. Getting lots of errors on this site tbh so it could be anything.

Happy for this to be marked as no bug though as a new clean install is working as intended.

1 Like

Thanks for getting back!