Brick Builder not saving changes

Bricks Version: 1.3.3
Browser: Chrome 92.0.4515.159
OS: macOS / Windows
URL: Home – Joris Jedamzik

After creating the hero section of my portfolio website, the Builder does not save the changes.

When I press the save button I get a success message, yeah!

When I click on preview mode I also get to see my design. However, when I click on view on frontend, all changes are undone. I have already tried the incognito browser etc. Nothing works…

Here is a video:
2021-08-30_20-25-58 - Brick Bug (1)

Hi @jorisboris,

is it possible that you´ve set a template with a condition set to post type page?
If so, delete the condition and your custom bricks page content will show.

Regards,
timmse

Hello Timmse,

No, that’s unfortunately not the case. Do you have any other suggestions?

Hmmm… another guess:

Save your layout as a template or copy everything to the clipboard, delete everything in the structure panel, save and check the frontend. If it‘s empty, paste the copied data or insert the saved template and save again.

In rare cases the structure gets messed up… starting from scratch is the last resort (shouldn’t take too long in your case :))

I have removed everything as you said. Tried again to create the design. Now the preview did not show what I had created in the builder, at least not according to the correct settings. View frontend was completely empty.

After refreshing the page all the content was gone again. This is getting really frustrating… I really like the builder, but there is always something that irritates me.

Video link: Klik here

Pretty strange :smirk:
Does this only happen on the home page or on every page?
Are there any errors in the console when saving?
Does your server fulfills the requirements (see system information in the bricks menu)?

I have created a test page, on which it also happens: Test – Joris Jedamzik

I also have other websites with which I test brick where I don’t have this kind of problem. They are all hosted on the same server with the same settings.

This has happened to me too, many times.

Mostly the changes that haven’t been saved have been minor (And the first times it happened I’ve questioned whether I ever saved the changes I made or not), but now that I’ve used Bricks for months, I’ve kept track of some changes I’ve made and I’m certain that it happens.

I am also facing similar issues with page save. When I save the page I either lose all the CSS classes or it still doesn’t work. This has happened on 2 of my websites and so far no help. Really sad :frowning:

Hey @kautto @phaptue ,
This problem is well over a year old, and there are about 16 versions in between. No one can say for sure what the problem was with Joris back then.

@kautto ,
As far as I can see, we do not have a report from you on this issue. If you can tell us how to reproduce the problem step by step, I look forward to your report.

@phaptue ,
Your problem was completely different and not a bug :wink:

2 Likes

Yeah sure, but how do you reproduce an issue that seems to appear randomly? :sweat_smile:

EDIT: Also, didn’t realize how old this post was (I thought it’s Aug 21st, not 21, lol)

We are asked to do this in 9/10 cases :smiley:

That’s correct, it’s my fault. It’s not bugs. However, instructions for Bricks users are required for things to remember like this: “Is there a missing “{” or a syntax error in your Custom CSS box? Because it is possible that an error is causing CSS rendering errors on the entire page.” It could be an essential tutorial on academy Bricks. I think so.

Good suggestion - I’ll add it to the list :slight_smile:

1 Like