WIP: Single Page template design isn't showing when editing a page

I’ve created a single page template, and applied it to a page.

I then used the template settings to apply the template to a page

When you edit the page, you don’t see the Template surroundings, everything takes up full width

The template:

The frontend:

Uploading: CleanShot 2022-07-13 at 13.09.45@2x.jpg…

When editing the page:


From what I understand, you’ve got to get used to the fact that your template’s contents won’t get pulled into the BB editor… You preview it on the frontend…

Yeah, seems strange though, as you can pull in header/footer templates. Hopefully this will be addressed too :slight_smile:

1 Like

Possibly related: Conditional Display Logic / Intended Behavior

I have been discussing this with @thomas already recently. Would love to have dynamic data visible in BB too (and not only shortcodes) …

Do we have any solution or ideas for this? It seems wrong to edit a full width page if my space to edit is only 50% for example…

1 Like

I guess this still applies…

1 Like

Thought so, but I was hoping for a planned feature that changes this…

Yeah, at least some default assignment of say “Entire page”. No big deal.

1.5.1 will fix it. It is coming with a toggle to preview dynamic data. Look at Thomas’s 1.5 release post.

1 Like

Isn’t this the setting…?

No, that settings just disables automatic display of the header for the whole site, for example.

If you check that, you have to apply conditions to every template you create. If it’s unchecked, header and footer will be shown on the whole page automatically.

Strange, look at what I get now…

Header (Template) - Google Chrome - 15 August 2022 - Watch Video

I wonder if that’s what Thomas meant by that option. I wasn’t sure what it was going to be from what he wrote :thinking:

I think it meant instead of {post title} it will show the dynamic title etc

1 Like

SOLVED: I just deleted the template (header), started over and now it works as it’s supposed to… Who know what it was

I still see this issue myself too… Headers and Footers load fine when editing a page, but not my Single Page template (i.e. if my Single Page template involves a section for the page title to be displayed, that section won’t load when editing a page which meets the criteria for the Single Page template). Any ideas here? Have I missed something or is this still an issue today even in 1.5.4?

Example how it looks if previewed in Single Page Template editor (and is how it should look):

Example of how it looks when editing the actual Pricing page this preview is generated with: (notice the lack of page title section)

Just realized I have what I guess is a duplicate post I created a couple months ago which I totally forgot about. Editing page in Bricks won't show the Single Page template included, only Header & Footer - is this expected?

1 Like

Would love to see this fixed up in the next release. :wink: Btw I know my own post kind of duplicates this so if we want to retire the other one or something that’s totally fine as well.

While editing various pages, this continues to annoy me as I often am guessing if I have a title bar or not and more because it’s missing from the pages since Bricks isn’t showing them in the template style. Please consider fixing this sooner than later, @Thomas :slight_smile:

when i click to add new post there is this page loaded i don’t know what’s happening