WAIT: Adding Classes to element wont save after refreshing browser

I don’t know why sometimes I can’t apply clases to elements, I need to reload the builder and still not applied .

Is it a bug?


Hi @yosnap There was a bug in 1.4RC2 that had issues saving classes, but i haven’t experienced it in the 1.4 stable.

Could you add what Bricks version you are using and which OS / Browser too as it will help support to diagnose it for you.

I will also move it over to the bugs section as i think this is where it is best to get the most help. :+1:

Bricks 1.4 (showed at min 1.05)
Google Chrome Versión 102.0.5005.61

I’m coming from 1.4RC, maybe that’s the issue

Have you tried pressing Ctrl/Cmd + Shift + S instead of Ctrl/Cmd + S?

Hi Paulo,
Is the site running on Cloudflare?
Are you using any form of caching?

Best regards,

Hi Tim,

The site is not using Cloudflare.

I’m using WP Fastest cache and the built form in Bricks

Well, then it’s probably a caching issue. Have you tried disabling the cache, clear browser cache etc.?
@Michael has mentioned a few tips here that you can also try:

I’ll take a look

Thank you Tim

Hi @timmse
Today, I encountered the same issue seriously. I was not able to apply the classes to any element. As a result, I am not using any cache plugin under development.

I am using Cloudflare. But it was the same even if I purged the cache on C.F.


I have finally applied the classes to the element. But I have refreshed the page so so so many times.

We’re also seeing this - sometimes things work, sometimes I need to reload the builder multiple times.

Firefox Dev and Safari. Across multiple sites.

1 Like

Hi Brendyn,
Welcome to the forum!

We definitely need a concrete way to reproduce the problem 10 times out of 10. There are so many gears meshing that “sometimes it happens, sometimes it doesn’t” makes it impossible to fix the problem, let alone identify it.

Please let us know if you find a way to reproduce the problem permanently :pray:

Best regards,

1 Like

Hi @timmse

Unfortunately, I can’t always reproduce. But it happened so many times to me that day.

Also was affected by this. Had to create a whole new container and rebuild the section. Then it finally worked after saving

If I can do it consistently then I’ll absolutely report it and loom it for you. Like the others it seems to be inconsistent. Either after inserting a container or a template but I can never be sure exactly the steps to trigger it :man_shrugging:

@brendyn Is autosave on (it is by default) in your Bricks settings?

Yes, I think it was - I’ve turned it off now. I’ve not done much on the site since though so I’ll have to wait and see if it happens again.