SOLVED: Invalid Post Type

Bricks Version: 1.5 beta / 1.4.0.2

I updated to the 1.5 beta and also updated wordpress to version 6. When I try to open bricks I get the following error: “Invalid post type.”

Also after downgrading to 1.4.0.2 again bricks gives me now the same error.

PS: Flushing permalinks does not help.

Try flushing the permalinks and rewrite rules once again?

@omega believe me, I did this a hundred times. But just for you :index_pointing_at_the_viewer: I did it another 10 times now… still not working.

I have the Same problem

Did you also flush the permalinks? And did you also downgrade to 1.4.0.2 again?

Hi Alexa & Giulio,
have you tried removing Bricks completely, activating another theme, flushing permalinks, and then reinstalling it afterward?

Also, deactivate any plugins that may be installed.

Alternatively, you can send temporary login credentials and a link to this thread to help@bricksbuilder.io using the email address you used during the purchase and we’ll have a look :slight_smile:

Best regards,
timmse

Hi @timmse,
After playing around for a while I found that it was related to some plugins. It took me some time to find out because reloading the page didn´t help to find the cause - since I was only reloading the error page. Beginners mistake…

2 Likes

Hi, I have the same issue on of my websites, which plugin cause the error?

Hello,
In my case it was the “Filter Everything” Plugin by Andrii Stepasiuk. With the newest Update of the plugin it now seems to work.

1 Like

thank u, i was facing same issue with different plugin

I am currently on v1.6.2 and got the same issue with my templates. But even disabling ALL plugins does not solve the problem.

I also tried exporting all the templates and importing them again, but that didn’t solve the problem either.

I can still use those templates, but I can’t edit them anymore.

Does anyone have any ideas?

With kind regards,
Chris

I have made one step further. If I change the status of the template to “Draft”, I can edit it. After the edits, I have to set it back to “Published”.

This behaviour is new. It was different before and it is different on another website.

Any help is very much appreciated.

Best regards,
Chris

Hi @Chris22 ,

Could you please check your server rewrite rules like .htaccess or nginx settings?
Maybe resaving your permalink settings will resolve the issue?
Otherwise, you could send your website temp admin access to help@bricksbuilder.io so we could log in and check on it.
Thanks.

Regards,
Jenn

Also getting this error on 1.6.2 with CPT’s.

Tried disabling all plugins, inc metabox and reactivating, and flushing/changing/resaving permalinks.

Again, if i mark as draft I can edit the post/page etc but as soon as its published i get the error. Frontend 404’s when post/page is published also but fine in draft frontend preview

@itchycode what nginx settings should we be looking out for or checking?

EDIT - Also on 1.6.1, 1.6 & 1.5.7 - so either serious bug or site errors somewhere.

EDIT 2 - worked out that my errors could be due to trying to edit a CPT child - new bug report here - MetaBox CPT hierarchical children Invalid Post Type

1 Like

@Jenn, thank you for taking on this problem - and solving it.