SOLVED: Invalid Post Type

Hello @timmse,
Things are getting very strange. After opening a template once from the template menu within Bricks (not from the Wordpress Bricks template menu), I can now open all templates again from the Wordpress Bricks template menu.

I deactivated all plugins and opening the template worked again. One of the last plugins was Custom Post Type UI but not sure as I deactivated several plugins at once.

Everything worked fine after reactivating all plugins again. Bricks 1.70

Hey guys,
As far as I can see there is no issue anymore. Basically, your problems probably came from incorrect rewrite rules like “/” or not saving permalinks after significant changes that can’t be tracked after the fact.

So, whenever you have “Invalid post types”, make sure to (one thing at a time):

  • resave your permalinks
  • remove custom PHP redirects
  • disable plugins
  • check .htaccess for custom redirects

Best regards,

Hello, we have created a custom post type (landingpage) and would like to remove the slug. We had used the below rewrite rule.

$rewrite = array(
‘slug’ => ‘/’,
‘with_front’ => false,

However, this break the template access in bricks. How would you suggest removing the slug without breaking bricks builder.