SOLVED IN 1.4: Firefox: rename in structure panel with double click doesn't work

Bricks Version: 1.4 RC
Browser:Firefox dev
OS: macOS

In the structure panel,
when I do double clic, the text is not selected (with cmd+A is working)
when I erase the las letter in the name, bricks “autocomplete” withe “oficial name”

1 Like

I confirm, can’t select with double click.

But I don’t mind the autocompletion when deleting everything, could be useful, I guess.

Auto completion could be nice only in case that you try to save without name, if not send buggy because I erase the name to put mine but “I cannot”

Hi Marco,
Thanks so much for your report!

I am able to reproduce the issue in Firefox (chrome works fine btw) and added it to our bug tracker.
The “revert to the original name” is intended but doesn’t work as it should in Firefox.

Best regards,

1 Like

You’re right, I usually use CTRL-A to select all then type something and in this case it’s OK.
But indeed you can’t actually delete everything with delete key THEN type your name :frowning:

That’s it!

I use shortcuts all the time too, but checking things I realize that was wired…

This still doesn’t work in Firefox for me in 1.4RC2.

If I double click to select, it selects the text and I can rename it.
If I click and CTRL-A, it selects the text, but I can’t rename it.

Yes, this entry is in “Work In Progress (WIP)”

Hey guys,
the issue has been fixed in Bricks 1.4.
Please let us know if you encounter any problems.

Best regards,