SOLVED IN 1.4: Adding CLAMP formula breaks control panel layout

Bricks Version: 1.4RC2
Chrome Latest
Windows 11

Hey Chaps,

I did search and could not see another ticket, but i do recall something similar.

Basically if you add a formula inside themestyles>container >root container margin it breaks out of the input boxes.

Please see image below:


Many thanks


1 Like

Hi Michael,
Thanks a lot for your report, but… :sunglasses:

I would recommend you in 1.4RC2 not to use var, clamp, min, max or anything else with brackets in the input fields.


:rofl: I did say i thought i something mentioned!! haha


Is this just temporarily until you guys find a fix? It’s pretty important for us to be able to add var and calc into these fields.

1 Like

Hey @ChrisCastillo This bug was introduced in 1.4RC2 so i would imagine this would be fixed for the final release.

1 Like

The error has crept in by extending/enlarging the input fields when using var(), clamp(), etc. and will of course be fixed in the next version.

However, you may have to re-enter the values, as the excess brackets are written to the database when saving. Therefore I would refrain from setting clamps or vars - generally anything with brackets - in RC2. This applies to all input fields, not only in the theme styles.

Big sorry for the inconvenience!

1 Like

I just hope 1.4RC3/Stable comes fast and well!


Hi Michael,
The issue has been fixed with Bricks 1.4.
The only problem that may occur now is that the broken variables (or functions) have been stored in the database and therefore do not work anymore.

So if you run into a broken layout somewhere, it is most likely due to a broken value in an input field like “var(var(–variable)”. Sorry for the trouble.

Best regards,

Thanks Stefan,

Just to clarify and for anyone else who stumbles on this post that to remedying any broken values require you to copy and paste in the variable again and save?

Could you just confirm that is correct please Stefan

Thanks again and keep on fighting!! :facepunch:

Yep, that is correct :v:

1 Like