SOLVED: Border color added by default by Bricks

Bricks Version: 1.6.2
Browser: Chrome and Firefox latest
OS: Windows

Each time I set a value (static or variable) inside the border-radius in the editor, Bricks adds a solid light gray border by default, as illustrated in the image below.
It happens on buttons, images, divs, spans, basically on every element, on the id level or a class it doesn’t matter.

The only fix I found so far is to add the border radius through the root class in a css panel, the one from the element itself or even a parent, both works.

2 Likes

Hi @webtools ,

Thanks for reporting this issue.
I am able to replicate this and already recorded it in the bug tracker.

Regards,
Jenn

1 Like

Glad I can help !
Franck.

Hi,
We’ve fixed this bug in Bricks 1.7 beta, now available as a manual download in your Bricks account: Account – Bricks

Please let us know if you are still experiencing issues.

Best regards,
timmse

1 Like

Hey @timmse,

Indeed, it’s fixed !
Thanks for the hard work.
Franck.

I’ve just switched to the 1.7 beta and I’m getting this bug again… I’ve setup borders in the builder and it’s ignoring that and showing a light grey. It’s also ignoring the animations that I’ve put on the borders (thickness was changing on hover before update). It’s behaving normally in the builder, just not working on the front end.

Hi Jack,
Welcome to the forum, and thanks so much for your report!

Can you provide me with a live link that shows the issue?

Best regards,
timmse

I am getting this on form elements (input text)? 1.7.3

Can you provide me with a live link that shows the issue?

I am getting this too. It appears that Bricks sets:

  • {
    border-color: var(–bricks-border-color);
    }

here is an example. If you click on one of the frequently asked question accordions you get a gray border: #1 Lake Como Elopement Packages - Sublime Weddings For 2!

Hi Jules,
The border you see is the :focus outline, which is there for accessibility reasons.

You can disable it within your theme styles » typography » miscellaneous, or add a separate :focus pseudo class for the accordion titles.

Exactly the answer I needed. Thanks!