NO BUG: Template on CPT not loading on frontend, maybe I'm doing something wrong?

Bricks version: 1.7
Browser: Safari 16.4
OS: macOS

I’m new to using a CPT with Bricks Builder so my apologies if I’m doing something wrong, but I’m trying to create a new template for the CPT “Courses”, and it’s not loading for some reason. Have I missed something perhaps, or is this a bug in 1.7?

Screenshots below showing the builder content in template, the settings for the template, and the frontend CPT course post.

I’ve tried adding Archive to the “applies to” portion too, but no change. Also tried changing from Single to Archive type just in case but same behaviour unfortunately. I’m really not sure why this template isn’t loading properly for the Course CPT.

Since your settings look correct to me… Is it possible that there are other templates in your list that apply to this post type as well and have precedence over this courses template? I saw a similar issue in the forum some days ago and I think this was the issue…

Sorry for the delay, haven’t had enough time this week to test again but I’ll see what I can find out with your latest suggestion. Hopefully I’ll have an update later this weekend.

I’m not totally sure what it was, but it seems like it’s been resolved when I started looking at it again today. Possible a weird cache thing in that case. Will keep an eye on it in case it happens again.

I have the same problem. ACF CPT services, but will not show when I do a NEW post or will not update when I change the template.