NO BUG: The content is not visible in the frontend

Bricks Version: 1.6.2
Browser: Chrome 90
OS: macOS

Bricks edited page content not shown at all frontend except for pages with a template whose content is Gutenberg content.

You have to add two post content elements in your template. One with a data source of Bricks and the other with a data source of WordPress.

Depending on the actual post content the “matching element” is used (and the non matching element does not get output in the frontend at all).

1 Like

Thank you aslotta! It’s still strange that in “old” Bricks sites I don’t have to need do it that way!? …hmmm… Anyway this was a great help! And apparently it’s not a bug at all. Happy Valentine’s Day!

Hey Jarmo, with “old” Bricks sites you mean which version exactly?

Hi timmse. I mean all my sites and demos what I was build from 1.5 to 1.6 works this way. And also today I tried 1.7 Beta and this time I can produce situation which works like in “my old way” e.g. page with Bricks content, but without (any) template works properly also in frontend. So in nutshell my test-site has only one template for all pages except Front-page which has bricks content. If you want see how its done I can make demo for you and share credentials to you.

Basically, you don’t need a template either, but the page has to be rendered with Bricks instead of WordPress.

Are you sure that you render the page with Bricks, and not with WordPress?

yes I’m sure and if I click to “Render with Bricks” it goes to straight to backend to the Wordpress editor. So if it’s not set up correctly, how can I choose to render with Bricks instead of Wordpress?

And here are screenshots for my template for all other pages than Front Page and WP’s reading settings.

Would you be so kind as to send temporary login credentials and a link to this thread to using the email address you used during the purchase, so I can have a look? :face_with_monocle:

I sent the login information. The title of the mail is “NO BUG: The content is not visible in the frontend”

Hey Jarmo,
Thanks for the credentials. To be honest, I don’t get the problem :smiley:

Thanks! :slight_smile:
But it happen again Dropbox - bricks-template-problem.mp4 - Simplify your life

So above link is to the video for that problem. Now also front-page stopped work.

I sent new credentials for you. Please check from frontend situation before you change settings etc.

If its only stupid user error, I’m a very amazed at how stupid I am. ;D

Hi Jarmo,

Thanks for the email with the login link.

Your template doesn’t apply in frontend it’s because of the OffCanvasMenu template.

You set it as Single template with condition set to Entire Website.

Your website has 2 Single templates with the same condition (with same score), so the earlier Id will be used in the Single page now. (OffCanvasMenu)

If you set that OffCanvasMenu template to section type or set it as a draft, you should be able to get your result as expected now.


Thank you Jenn. Now it works!! So it was a stupid user error. :slight_smile:

I am very relieved. Thanks again for your help.

A small mistake that I didn’t see no matter how many times I went through the settings and templates. A new pair of eyes is always in place. And luckily it wasn’t a bug, because this bothered me so much that I even had some sort of nightmare about it last night. ;D

Best, Jarmo

No worries, we are sharing what we know.
You are welcome :slight_smile: