NO BUG: Can't edit templates

Bricks Version: 1.5.1-rc
Browser: Brave 105
OS: Windows


I just set um a new installation. Everything seems to work finde but now I realized, that I can’t edit my header template I created. When I click the “Edit with Bricks” button an 404 error page shows up.

The URL in the browser is …/template/header/?bricks=run

I already tried different PHP versions but without success. The weird thing is, that the builder loads on regular pages without any issue.

Anyone an idea what can cause this problem?


Hi, maybe try refreshing the Permalinks. Settings > Permalinks > Just hit Save Changes and try accessing the template again. I had this issue recently, it wasn’t a 404 but a post type error. Refreshing the Permalinks did the trick

1 Like

Hi, thanks for the tip but unfortunately that doesn’t solve the problem.

Any other ideas?

Error code is different. But not sure if this is related. SOLVED: Home page url edit with bricks show Server Error 500 - Bugs - Bricks Community Forum (

I also found this and I had this exact problem in the past when I tried Bricks before. But I think in this case the editor didn’t work at all. In my case it works with normal pages.

I think this solution also only for Apache servers if I’m not wrong. I’m running nginx. But when I thought about this problem yesterday I switched to Apache and applied the fix but it had no effect.

I think I found out was causes the problem.

I made a complete fresh Wordpress install and everything works fine. I could edit templates without problems.

Then I made some adjustments ins the Wordpress settings and as soon as I set the permalink settings to “Post name” the 404 error showing up again when I try to edit a template. When I switch permalink style back to “Plain” everything works fine again.

So this seem to be the issue. Is this an 1.5.1-rc problem and no one has this with 1.5?

Hi SideWinda,
so you’re using an nginx server and which PHP version?

Is the site publicly accessible? If so, you are welcome to send us temporary access data and a link to this thread to

Best regards,

I am on PHP Version 8.0.22

I just send you an E-Mail with the Login credentials.

@SideWinda @timmse did you manage to crack this?

I’m having the exact same issue. When permalinks are on ‘post name’, I get a 404 page when trying access the templates.

I’m currently on PHP 8.2.6 , fresh WP install.

Any ideas how to fix this?


Solved - Corrupted .htaccess file was causing the issue.

1 Like

Hey guys,
We missed answering this thread back then.

The original issue from SideWinda seems to be related to the hosting since it happens with a default theme as well. So it’s not a Bricks issue and therefore, not a bug.

It would be great if you let us know what your hoster said about this and whether you have found a solution in the meantime @SideWinda :v:

Best regards,