Bricks & Local WP

Hi there.

Here comes a little weird thing.

I´m working (or try to) with Local WP on PC - what needs a little tuning to get it running with nice performance. That out the way - here comes the strange behaviour:

The WP backend is really fast. But the frontend… uhhh! What has this to do with Bricks? That´s it. It seems to be the only theme where this slowdown happens. All ‘standard’ WP themes + some tested like OceanWP are blazing fast. Only at Bricks the site takes about 5 seconds to build up.

Somebody around who stumbled upon this too? Or any ideas what could cause this?

Even stranger… I had a Local WP installation where it worked well. But no chance right now.

With a little debug helper the view is much clearer now. The bad guy seems to be the request of the Google Fonts : google-fonts.min.json

Takes around 4 seconds.

Have to wait for 1.4 to get it deactivated.

Hi Sascha,
I haven’t had any loading time problems with LocalWP and google fonts so far.

Where and when is google-fonts.min.json loaded in the frontend?

Best regards,

Hey timmse.

Here are 2 screenshots that lead me to this guess.



As written in the initial post I´ve got this running smooth before - but for now it´s the only anchor I have.

Best / Sascha

Hmmm… let’s see if it still happens with the upcoming Bricks 1.4 :sunglasses:

Hope dies last … and it´s about time! :slight_smile:

Hi Stefan.

Have to get back to this with some more testing done today. I can´t hang loose from ‘Local’ as I´m so close… :wink:

Installed the plugin ‘Query Monitor’. And - it´s not only about deactivating the Google fonts via filter. It seems there are happening HTTP API Calls with bricks - that cause the slowdown.

Loading the default post page in frontend with no content (images) it takes milliseconds to generate the page. If I put some content like images inside Bricks do these API Calls and it takes around 4 seconds for every call.

Also - using a different theme the calls want happen.

This is not my ground - so maybe You have a guess what´s the matter?!

Thx for Your time!

I had slow performance issues with LocalWP. Disabling php x-debug solved it for me.

thanks for reporting back!

I use LocalWP on both a Windows 11 machine and several Macs and have never had these problems. Can you possibly create a screen recording and explain what happens, so that we can understand it a bit better?

Please also try Omega’s suggestion, maybe that helps already :v:


If You´re talking about these lines in the php.ini - I did that already:

;zend_extension = php_xdebug.dll
;zend_extension = {{extensionsDir}}/


Sure - You find it here : Nextcloud

@shenom: Yes. I was talking about that only. You may try the below and see if they make any difference for you.

  1. Can you also try disabling “Magic Sync” from Settings?

  2. Router mode to localhost from Settings?

  3. Excluding Local Site Folder from your Antivirus Program.

  4. Changing db host in WP config from localhost to

Ofcourse restart local wp after making the changes.

Thank You!

Yes - i have been through this journey at the Local forum! :slight_smile:
One thing was not set for me - the Router ‘localhost’. This really makes a change to the frontend speed.

Still wondering… could it be a SSL issue? I have installed the ‘Query Monitor’ on a test live site with Bricks and it makes the API Calls as well - only much much faster. The difference I see is the HTTPS protocol.

My experience in Local is that despite Router Mode ‘Site Domain’ the page does not really load with HTTPS. Is this normal?

1 Like

You are welcome!

Possibly. I suspect the same. The issue is only occuring on Windows though. Not on Linux or MacOS. So not able to pinpoint what was causing it. You can run WSL with GUI & install local on Ubuntu instance. I just use local wp for occasional testing. I prefer dev environment on a vps instance.

There are also other tools like lando, laragon and devkinsta which you may give a shot.

the problem is php8, use 7.4.1

Not in my case - this WP install is running with PHP 7.4.1

I´ve tested DevKinsta - what has a good performance. But I´m missing things like export / import, clone sites, etc.

For now it looks like the Router Mode ‘localhost’ is doing well for me.

Thanks again for finally let me work with Local! :slight_smile:


Happy to help. I will post here if I notice any improvements in future updates.

@shenom I have got rid of Local WP & migrated to Laragon. It outperforms Local WP in terms of performance and allows me to use ssl at the same time. It’s windows only. I am very impressed with the performance.

Cool - I´ll give it a try very soon. Thanks so much!