Woocommerce Single Product Template Populate Content

Hi, as shown in the attached image there does not seem to be an option to select a product in Template Settings->Populate Content->Content type or am I missing something. I am using Bricks 1.6 beta.
Any thoughts / help appreciated

Hi, I need help with this too, I use Bricks 1.8 but I cant choose product…

Try type one product name and it will appear then

1 Like

Hi, I also need help with this, tired to type the product name but unfortunately it did not work, tried also Content type as Search result but still no success.
Bricks version 1.8

Hi guys, is there really no solution to this issue? It seems strange to me that there’s no solution after more than a year.


As some friends mentioned, you must type the name of the desired product to be displayed. I agree, it is really misleading especially for those who are trying it for the first time. Personally, I was not aware of this issue on the first day and had problems previewing the products.

Have the same issue and typing the product name doesn’t work. I’m on 1.9.2

I can’t believe this issue hasn’t been satisfactorily addressed yet (November 2023). In one YouTube video products appear in the Single Posts list but I only get pages. At present, this is totally unusable for me so I can’t believe it’s a problem for everyone.

Under settings, template settings, populate content select single post/page. Then search for the name of your product.