WIP: Show English text in editor in Builder for none-English sites - In Woo templates

Hi
Hope you are well,

There is an important problem in showing the language in the builder in combination with the language of the site for none English websites. I’m not sure but I think that was fine before and in the latest version(s) it is changed.

Test and Images are for Woocommerce cart template. But I think is will accrues in many cases that there are some texts that related to other plugins like Woocommerce. So please consider this for all other cases as well.

Current State:

  • The language of the site is not English. (Like Farsi and it is RTL)
  • The language of builder set to English and LTR. (So I can manage all languages always with one Interface in multilingual and non-multilingual websites and also I’m always working with the same builder interface.)
  • The language of some texts related to other plugins - in this case Woocommerce - in the editor is not the current website language. (which should be and this is a problem)

Desired state :

  • The language of the Site in not English (Like Farsi/Persian) ,
  • The language Of the Builder is English
  • The language of editor for all plugins is as same as the language of the website.

Solution: The language of BricksBuilder interface like structure and style … must be how I set in BricksBuilder setting (which is OK now and works fine, English is my desired for that) – BUT the language of Editor for Woocommerce ( Green arrows and rectangle in the second image) must be the current language of the website (which is not English and must be works with WPML too), so I can see how fonts and styles are in that language(s).

If I change the language in bricks builder to the language of the website, all BricksBuilder interfaces become non-Englishm which is not good at all. I have to realize which one is the translation of which in English, and this is too bad.

Kind Regards

Hi @hosi,

Yup, you’re correct, WooCommerce elements should load in the current page’s language (not the builder language). I have added this to our internal bug tracker :slight_smile:

1 Like