WIP: Builder language stuck at site language, not profile nor builder language

Thanks for the info. I have added it to the task :+1:

This is interesting as well.

Another example

Another one.

Now, even more in “Site language” than before.

WordPress: 6.3.1
Bricks: 1.9
Bricks Child: 1.1

Site language: German
Profile language: English US
Bricks builder language: English US

As far as I checked, every element is in German language.


Profile language
bricks-01

Bricks builder language
bricks-02

Site language
bricks-03

Builder
bricks-04

@Niko_S, I have the same problem with the Smash Baloon plugin - have you resolved it somehow? Thanks for the info.

@Blackeye no, the issue persists on my end too.

The fact that this stays WIP for such a long time, now starts to get jarring.

Is there really at least one person, who has learned Flexbox in German language? I seriously doubt that because in CSS, we have to use English anyway.

And, what do these German words even mean? “Flex wachsen”, seriously? Jarring! Damn it: A loop is loop, grow is grow, and Umhüllung I really don’t know that’s supposed to mean.

Or, allow me to switch Bricks to English, reliably. Please.

For everyone struggling with the unwanted Bricks’ translations, this code helped me. Yes, a bit hacky way, but at least it makes the editor usable…

function bleye_unload_textdomain_bricks() {
	unload_textdomain( 'bricks' );
}
add_action( 'init', 'bleye_unload_textdomain_bricks', 10 );
2 Likes

Thank you for this workaround. I had the same issue that the language I’ve set under Bricks » Settings » Builder » Language has no effect and I always see the (not so brilliant) German translation instead of the English version which I have configured.

BTW: Maybe it’s related to WPML which we have in use?

1 Like

@Blackeye
Thank you for the snippet, it works. Any potential side effect we should be aware of?
@martin.sauter
For me, it is indeed WPML that messes things up, more precisely the String Translation plugin.

@Seccyeth
I’m just finishing my first site in Bricks and in fact I don’t have to use this code anymore, because I replaced the plugin causing the issue by another one. So I can’t tell for Bricks.

But I’ve been using this code for several years in Elementor without any issue so far.

Hi, for me it was the child theme…

1 Like

Wow, I can confirm that.

Switching off the child theme solves the issues. Even when drilling down into “dynamic conditions”.

Thank you very much @fily1212

Hi guys,
Sorry that the task is still in progress. The hint with the child theme is good though.

I have created a separate task for this and linked it to the existing one for the problem initially reported here. It may be related. Thanks for the hint @fily1212 and welcome to the forum!

Recently, our website started to display Bricks in French, which is one of our website languages, but unfortunately not the one I am fluent in, and…

– not the language defined in the Bricks setting
– not the default languge of the website
– not the language preference in my WordPress profile
– not the language preference in my browser

In my earlier post I suspeced an issue with WPML, but this website runs on Polylang. So there must be a basic problem with the Bricks language seetings, it is around for a long time now, and it really needs to be addressed quickly now.

1 Like

same here. Hopefully fixed soon.

2 Likes

I had the same issue.

I am using WPML. Turning off the child theme fixed that issue for now.

Hopefully, this bug will be fixed soon.

1 Like

any updates on this? thanks!