SOLVED: Wrong Term loaded in frontend when populating content for a term archive

Bricks Version: 1.6.2
Browser: Brave – doesn’t matter
OS: macOS
URL: Zero Hunger – Default Title

When I try to fetch an ACF field OR using the following code in a custom taxonomy term archive it queries the term applied in “populate content” for the template instead of the actual current term.

global $wp_query;
$term = $wp_query->get_queried_object();
echo get_field($fieldname, $term->taxonomy . '_' . $term->term_id);

When I remove the populated content it works again.


Hi Jonathan,
Thanks so much for your report!

I just tried to reproduce the problem, and it only seems to occur when the term contains no posts.
So instead of “Sorry, no (whatever) posts found.” it shows the “populate content” data. Can you confirm this?

Best regards,

Hi Tim, sorry for the late response. Yes, I can confirm that.

kind regards, Jonathan

@timmse, any fix for this issue? I experience the same on a new WC build. Every product archive that’s empty display some unrelated products, and not a message saying we don’t have any in that category.

Hi guys,
We’ve fixed this bug in Bricks 1.7.1, now available as a one-click update in your WordPress Dashboard.

Please let us know if you are still experiencing issues.

Best regards,