SOLVED: WP_List_Table error on wpengine

Browser: Chrome 110
OS: macOS / Windows / Linux / etc.
URL: Link to a page that illustrates this issue
Video: Short screen recording that illustrates this issue (free tool:

I host on Wp engine. I was working on an existing site when I got a critcal error from the Bricks theme (already installed for months) I could not figure out the issue and since I was not happy with how the site was progressing anyway, I created a fresh wordpress install and decided to just start from scratch.
Upon trying to install Bricks I get the following error messages:

Uncaught Error: Class “WP_List_Table” not found in that submission-table.php

This error keeps increasing: PrivateBin
You will need to have the theme developer check out the Class “WP_List_Table” within the /themes/bricks/includes/integrations/form/submission-table.php file.

The only way I can get into the dashboard is via recovery mode. Also contacted Wp Engine see if there might be anything on their side preventing the install and they said no.

Lastly I tried a manual ftp upload of the theme and the issue still exits.

most recent update - the issue seems resolved but I dont understand it and am concerned about how much time and effort it took. Below is the final conversation with wp engine support (and again the issue seems resolved)
How great that worked! I can see the site is loading on my end as well now! So it seems that either this theme or some other plugin on the site may need to run on PHP 7.4. Though the error logs were indicating that the theme was the issue. Let me grab the error for visibility:

Here is the error, it’s a bit of a doozy, but this is something you can show to the Brick support team (assuming the theme is supposed to work on PHP 8.2).:

15 PHP Fatal error: Uncaught Error: Class “WP_List_Table” not found in /nas/content/live/travelwebsite1/wp-content/themes/bricks/includes/integrations/form/submission-table.php:6#012Stack trace:#012#0 /nas/content/live/travelwebsite1/wp-content/themes/bricks/includes/autoloader.php(30): require_once()#012#1 /nas/content/live/travelwebsite1/wp-includes/plugin.php(122): Bricks\Autoloader::autoload(‘\integrations\f…’)#012#2 /nas/content/live/travelwebsite1/wp-content/themes/bricks/includes/admin.php(69): add_filter(‘set-screen-opti…’, Array, 10, 3)#012#3 /nas/content/live/travelwebsite1/wp-content/themes/bricks/includes/init.php(124): Bricks\Admin->__construct()#012#4 /nas/content/live/travelwebsite1/wp-content/themes/bricks/includes/init.php(63): Bricks\Theme->init()#012#5 /nas/conten
t/live/travelwebsite1/wp-content/themes/bricks/includes/init.php(185): Bricks\Theme->__construct()#012#6 /nas/content/live/travelwebsite1/wp-content/themes/bricks/includes/init.php(193): Bricks\Theme::instance()#012#7 /nas/content/live/travelwebsite1/wp-content/themes/bricks/functions.php(131): require_once(‘/nas/content/li…’)#012#8 /nas/content/live/travelwebsite1/wp-settings.php(611): include(‘/nas/content/li…’)#012#9 /nas/content/live/travelwebsite1/wp-config.php(119): require_once(‘/nas/content/li…’)#012#10 /nas/content/live/travelwebsite1/wp-load.php(50): require_once(‘/nas/content/li…’)#012#11 /nas/content/live/travelwebsite1/wp-admin/admin.php(34): require_once(‘/nas/content/li…’)#012#12 /nas/content/live/travelwebsite1/wp-admin/index.php(10): require_once(‘/nas/content/li
…’)#012#13 {main}#012 thrown in /nas/content/live/travelwebsite1/wp-content/themes/bricks/includes/integrations/form/submission-table.php on line 6

Please help


1 Like

There was a post in the FB community about this same topic about the same time hosted on WPEngine. Is this you, or are there 2 people experiencing the same problem? (Error on WP_List_Table)‘

we are having also this issue.
We are hosting on WP Engine, what does the FB topic talk about ? I cannot see it from the link.

Reading the error it seems to me that it’s trying to find an active template, but is unable to.

It seems the error is tied with using add_filter(), I tried adding this before to PHP. And then the issues started, I didn’t notice right away because it throws occationally.

add_filter( ‘bricks/active_templates’, function( $active_templates, $post_id, $content_type ) {}, 10,3)

When removing the add_filter() line, I get another error…

#0 /wp-includes/plugin.php(205): WP_Hook->apply_filters(Array, Array)
#1 /wp-content/themes/bricks/includes/database.php(407): apply_filters(‘bricks/active_t…’, Array, 14, ‘content’)
#2 /wp-includes/class-wp-hook.php(324): Bricks\Database::set_active_templates(14)
#3 /wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters(NULL, Array)
#4 /wp-includes/plugin.php(565): WP_Hook->do_action(Array)
#5 /wp-includes/class-wp.php(830): do_action_ref_array(‘wp’, Array)
#6 /wp-includes/functions.php(1336): WP->main(‘’)
#7 /wp-blog-header.php(16): wp()
#8 /index.php(17): require(‘/nas/content/li…’)
#9 {main}
thrown in /wp-includes/class-wp-hook.php on line 324

Adding the filter back to PHP brings back the original error:

PHP Fatal error: Uncaught Error: Class “WP_List_Table” not found in /wp-content/themes/bricks/includes/integrations/form/submission-table.php:6

Any fix? Having the same issue with hosting with wpengine

It’s happening all over our sites too.

Only patch that has it back up for me is reverting to PHP 7.4

@tnosko @Ben @Bender @Nora
I’ve been in contact with Bricks and they found a temporary solution, but this will be swept if you do a next Bricks Builder version upgrade.

Hopefully Bricks can get in contact with WP Engine and figure this out.

You’d need to edit with following changes in file

1 Like

Hi guys,

Since it only happens in the WP Engine hosting environment, we sent an email to WPEngine a few days ago to find out what’s the reason the WordPress WP_List_Table PHP class is not loaded at that point.
We will put this thread remained as “WAIT” now.


Hi, I’m a product manager from WP Engine. We are investigating the issue and working with the Bricks team to come up with a solution. I understand this post was originally created on March 23, 2024 and the line of code it is referencing has been in Bricks since version 1.9.2 released in October 2023.

If you are a WP Engine customer experiencing this error, please share the date/time when you first became aware of the error so that we can review any other platform activity that may have taken place around that time.

If you need a temporary workaround, one customer’s site that was experiencing the error was restored by downgrading from PHP 8.2 to 7.4.

We will continue to work with the Bricks team to identify the root cause.


Well, I got this exactly same error also on “” dedicated hosting. So please be aware that this is not only happening on WP Engine servers. If you need more information please let me know, btw I am about to reach the support with full error log about this issue.

@kevin_wpe Hi Kevin, we noticed it on March 25th, but could have started earlier also, because 25th is when we came back to the office after the weekend.

1 Like

Hi Kevin, the issue also appeared for me around March 25th.

1 Like

I just created a new site on WP Engine and was unable to replicate the error with the following settings:

  • PHP 8.2.14
  • WP 6.4.3
  • Bricks
  • First tested single site, then converted to multisite—both worked as expected

I have also reviewed existing support tickets and found a few mentions of this WP_List_Table error occurring with the Bricks theme and the Imagify plugin.

If anyone has a WP Engine site currently experiencing this error, and you can provide steps to reproduce the error, please let me know and we’ll investigate.

I can confirm that we are still experiencing this error. I wish I could give you the exact steps to reproduce it, but it seems to happen entirely randomly. If you would like, I could grant you access to our environment so you can run your own tests. DM me?

1 Like

I don’t have DM privileges here yet, but I’ve reached out to Ben via email and will follow up here with our findings.

1 Like

Thanks to @Ben, we now we have a reduced test case which I’ve shared with the WP Engine platform team. The error seems to occur randomly across WP Admin pages but goes away after a page refresh. I captured everything I can find about the error in our support tickets and the Bricks forum and handed off the issue to our platform specialists. I’ll try to follow up when we know more. In the meantime I’ll share some known workarounds for Bricks users and Imagify users who seem to be encountering a similar WP_List_Table error.

Error Symptoms

The error appears in the browser as a critical error screen:

The error appears in logs as:

Fatal error: Uncaught Error: Class "WP_List_Table" not found...

Known Workarounds

  • Downgrading the server from PHP 8.2 to PHP 7.4 appears to make the errors stop.
  • OR Bricks users can modify the Bricks code to use a function that avoids extending the WP_List_Table class.
  • OR Imagify users can download the Imagify helper plugin provided by that plugin’s developer.

Any update on this yet? This is messing with quite a few of my websites, and need a fix urgently. Yes I have downgraded to 7.4 which is not ideal

I know this isn’t a permanent fix and not ideal at all, but for the time being, this fix worked very effectively without having to downgrade your PHP version.

1 Like

Hi guys,

An update from Bricks. We will change our code in the next release to tackle this issue.


1 Like

Yay! Now we just hope the update comes soon.

1 Like