SOLVED: Wordpress reports an error with Bricks after updating from 6.3 to 6.4

Bricks version: 1.9.2

After updating from Wordpress 6.3 to Wordpress 6.4 i’ve got this error message.

I’ve replaced the account and domain data in the paths.

WordPress-Version 6.4
Aktives Theme: Bricks Child Theme (Version 1.1)
PHP-Version 8.2.9


Ein Fehler vom Typ E_ERROR wurde in der Zeile 127 der Datei /www/htdocs/myaccount/mydomain/wp-content/themes/bricks/includes/admin/admin-screen-system-information.php verursacht.

Fehlermeldung: Uncaught Error: Call to undefined function Bricks\mysql_get_server_info() in /www/htdocs/myaccount/mydomain/wp-content/themes/bricks/includes/admin/admin-screen-system-information.php:127

Stack trace:
#0 /www/htdocs/myaccount/mydomain/wp-content/themes/bricks/includes/admin.php(1070): require_once()
#1 /www/htdocs/myaccount/mydomain/wp-includes/class-wp-hook.php(324): Bricks\Admin->admin_screen_system_information(‘’)
#2 /www/htdocs/myaccount/mydomain/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters(‘’, Array)
#3 /www/htdocs/myaccount/mydomain/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
#4 /www/htdocs/myaccount/mydomain/wp-admin/admin.php(259): do_action(‘bricks_page_bri…’)
#5 {main}

hi @DLR ,

Thanks for the report and we can replicate the issue.
Recorded this in the bug tracker.


yes, I confirm, there are problems after updating to 6.4, disabling all plug-ins does not help. The problem occurs on many sites. Yesterday at 10 p.m. I posted it on the Facebook group, probably the first one, communicating the problem.

Hi @Kris ,

May I know what other issue you face other than the System information page?
What we can replicate locally is just the error when landing on the Bricks > System Information page


Adding a new page causes an error. So the existing sites work but you can’t add a new one using wordpress.

There is also a blank space in the admin panel.

Chrome 119.0.6045.105
Mac OS 13.6.1 (22G313)

PS: Creating a new page works for me.


Could it be any third-party plugin causing the issue?
We tried locally but adding a new page or new post is all working well.
Alternatively, please send login credentials to for us to check.
Kindly use your purchased license email for communication, and include this forum thread URL as a reference.



I am sorry that we can’t replicate that as well.
It should be some other plugins generating errors and you turned on WP_DEBUG.

By the way, may I know are you using or selfhost?

Please send login credentials to for us to check.
Kindly use your purchased license email for communication, and include this forum thread URL as a reference.


I can report that everything works fine here for me with WP 6.4 and Bricks 1.9.2 after updating WP from 6.3 to 6.4.

I tested it on 2 WP installs.

Creating new pages works and also the Bricks editor works.





Credentials sent.

even if I turn off all plugins, there is still an error.
I’m sending it to you by e-mail because as a new user I can’t add a photo here.

It was only doing it when viewing the system info in Bricks for me. WordPress v6.4.1 update fixed it for me.

I can no longer edit pages with Bricks after updating to 6.4. When I click the Edit With Bricks button, it logs me out and brings me to the login screen.

Thanks, 6.4.1 fixed it for me too

1 Like

I was having similar problems. I don’t know if it will help, but what worked for me was opening a new tab and logging in to wp-admin there. Then I was able to reload the Bricks UI


Please check if that’s your browser cache. It’s not related to Bricks.
Try open the Incognito browser and test.

If still unable to edit or open page, please deactivate all plugins to check if the issue cause by Bricks.


Hi @DLR ,

As per my email reply, the gap is caused by some style changes in WordPress 6.4 (WP add margin-top: 32px for html since 6.4 )

This is replicable if the WP admin bar is enabled in Bricks editor. (either by plugin or custom code)

We will fix this in the next release.


1 Like

Hi @itchycode,
Is there an estimate when the next version will be released?

Thank you,

Hello everyone,

I also have the problem with this line 127 indicated… except that ALL pages are then no longer accessible, with a 404 error, blank, page not found with header and footer ok…

I’m looking into it, deactivating plugins, clearing cache etc. but no solution yet.

Hi @iqbalmauludy ,

I am sorry that I don’t have an accurate ETA yet for the new release.

Hi @ccNicolas ,
The error message will only be there if you are on system information page + WP 6.4. If you update to WP 6.4.1, the error will be gone.

Regarding your “pages gone” issue, it seems like not related to the WP update. Can you check if you have any single template set to the entire website? Kindly provide a screenshot of your Bricks > Templates page.