SOLVED: WooCommerce Loop + WP Grid Builder Facets shows placeholder image instead of featured image after filtering

Browser: Chrome 110
OS: / Windows
URL: https://staging.elementojade.pe/
Video: Short screen recording that illustrates this issue (free tools: birdeatsbug.com or jam.dev)

Hi, I have a template created for Woocommerce store with a query loop created with the featured image of the product with WP Grid Builder filters and every time I activate a filter the featured image is changed by the placeholder that has woocommerce, I do not know very well why, if I update the page with the filter the image is fixed, but if I return to use the filter, pagination or something else the same thing happens again. I have looked if in the console there was a problem, but I have not found anything.

I commented this error to WP Grid Builder support, and they told me “This is a problem with Bricks that should be fixed in the next version of Bricks”, but I still wanted to comment it here in case someone else has the same error as me.

The page is:
https://staging.elementojade.pe/tienda

1 Like

Hey,

This likely has to do with bricks lazy loading. I bet if you disable it, the images won’t switch to placeholders after filtering.

If you don’t like that option, the most likely solution is to run bricksLazyLoad(); after each WPGB event. I don’t have WPGB, so I can’t give you much direction but you can check out their docs and possibly reach out to them for further help.

Hi Smith,
Thanks so much for your report!

We have already received a ticket about this problem. Curtis’s approach sounds good at first but doesn’t help in this case. As I said, we already have the issue on our radar and are trying to find a solution as soon as possible.

Best regards,
timmse

3 Likes

@Smith_Benites, I’m having the same issue. Lazy load was disabled from the start, so cannot be this.

Can you confirm if this fix be in the next release, @timmse?

This has just come up for me in a new build - hopefully it’s a prompt resolution, because it’s making me look really bad right now

Also, definitely not lazy loading for me, as it’s disabled right from the start of all my builds

Yes, this would be awesome to fix. I’m just running into this problem right now. Except in my case, when I use the load more facet in the query loop (query loop is querying woo products), the featured image is pulled from the featured image of the current page, not from the product.

The first 12 items (the initial query) display fine, but any load more or pagination causes this problem.

Thank you, @timmse, @thomas, and the rest of the Bricks team!

I can confirm 1.7.1 resolved this issue for me.

1 Like

Yes, equalization also fixes the problem.

Thank you! :raised_hands:

Hi guys,
As you have already noticed: We’ve fixed this bug in Bricks 1.7.1, which is now available as a one-click update in your WordPress Dashboard.

Please let us know if you are still experiencing issues.

Best regards,
timmse

1 Like

Hi @timmse , looks like I’ve got the same issue on my setup:

Bricks: Version: 1.8.5
WPGB: Version 1.7.3

Hi Kennedy,
Would you be so kind as to send temporary login credentials and a link to this thread to help@bricksbuilder.io using the email address you used during the purchase?

Thanks for the login credentials. I was able to reproduce the issue and added it to the bug tracker.

2 Likes

Hello, I appear to have a similar issue, or at least no dynamic images being are being shown once a facet query has been carried out and I think it has also once shown the placeholder instead. I am using Bricks 1.9.4, WPGridbuilder 1.8.1 and WPGridbuilder Bricks 1.1.5.

I am querying wooproducts in a bricks query loop via custom taxonomy. There are a number of facets. Everything works apart from the images…

If I just have a ‘static’ image set in the card in the query, so it would be the same image on the card for every result, then an image is shown every time. I have tried using the woo placeholder, a set featured image and even creating an image custom field using metabox and whenever a facet query is carried out the images disappear.

I have also tried disabling caching in a variety of ways.

Apologies if this is not quite relevant to the original question.

FIX - i used an ‘image’ component and had the featured image used as the background and now it works correctly as expected with the image shown when a facet query is carried out.

Hi guys,

This issue has been resolved by WP Gridbuilder team in v1.2.0

Thanks.

Regards,
Jenn