[SOLVED] Undo (CTRL + Z) behaviour in Code Element / Custom CSS

Bricks Version: 1.5 Beta
Browser: Firefox 102.0.1
OS: Windows 10
URL: Youtube video demonstratring the issue

Yesterday I posted on Bricks Community FB group this problem I had by using CTRL + Z when editing a Bricks Code Block. Today I made some testing to replicate the issue and recorded a video to show what’s happening.

Basically my steps were:

  1. I deleted a test section (let’s call it sec2).
  2. I edited the id for another test section (let’s call it sec1).
  3. I added some Custom CSS on a Code Block inside sec1.
  4. I edited the Content on that Code Block.
  5. I pressed CTRL + Z to undo the edit I just made to the Content on that Code Block. Instead of undoing the edit, Bricks undid all the steps above.

It can get frustrating because when I’m writing something or if I paste a code and want to Undo it, pressing CTRL + Z messes up all I’m doing—and if I try to Redo by pressing CTRL + SHIFT + Z sometimes it doesn’t go back to where I just were. At other times I just want to keep pressing CTRL + Z a few times to get to a previous state, but as it is now that obviously wouldn’t work as intended.

1 Like

Just noticed that the same happens when editing Custom CSS: Youtube video

1 Like

Yep. It’s an annoying thing. Hope it gets fixed.

Same thing happens for me at least once an hour. I’m using Safari 15.5 currently. CTRL+Z will undo multiple steps and redo doesn’t return it to the previous state. Usually have to manually redo lost steps. Also doesn’t seem to be related to anything specific. It happens when adding padding, margins or making typography changes. Hope this helps get it fixed.

Hey Lucas,
Welcome to the forum, and sorry for the late reply, I completely missed this post.

We already have some reports about the issue and will address this soon, though probably not in 1.5.

Best regards,
timmse

This should have been fixed in the latest 1.5 RC2 :partying_face: If not, please let me know here. Thank you so much!

2 Likes

As far as I tested, it seems to be solved now (1.5 stable). Thank you!