SOLVED: Unable to save edits in page settings > custom code

From my testing this is new to 1.9.1

Problem - Unable to edit code inside page settings > footer script. It doesn’t save the changes. Only if you delete the entire code and then save and re-enter, you can no longer just make small edits.

See video below, but here’s the exact steps to replicate.

  • Add any code to the page settings > footer scripts (haven’t tested the other code fields)
  • Save the page and refresh the builder.
  • Go back to the page settings to find your code. Make an edit to that code (without deleting the entire thing)
  • Save and refresh the builder.
  • Go back to the page settings. Notice the changes aren’t being saved.

In order to make an edit, the code field needs to be emptied. and then save, and then paste it all back in. But if there is existing code there, it doesn’t appear to be able to save.


I have the same problem trying to save a script in the Body (header) scripts. I have to edit it, cut it, save, edit and paste, then save again. It ran me crazy trying to figure out why the changes didn’t work!

This happens on my hosting and my PC both.

Video: Recording #43

Windows 11

Hi guys,
Thanks so much for your reports and sorry for the late reply!

I’m able to reproduce the issue and added it to the bug tracker.

Best regards,

I have this same issue, also same if I try to save in the page settings custom code. it seems to be okay with short values but not with long scripts, almost like it is trying to validate the code entered even though the code if valid not saving or giving an error. E.g. this script fails for me

	window.onscroll = function() {scrollFunction()};
  function scrollFunction() {
    if (document.body.scrollTop > 5 || document.documentElement.scrollTop > 5) {
    } else {

In settings, under Builder >> Control Panel >> Disable auto-expand (Text editor, Code)

Turn the auto-expand off as a workaround.

Hey David,
We can no longer reproduce the problem with the current version - can you confirm this?

Seems to be resolved now.