SOLVED: The LOGO element does not display the image properly

Browser: Chrome 110
OS: macOS / Windows / Linux / etc.
URL: Link to a page that illustrates this issue
Video: Short screen recording that illustrates this issue (free tools: or

[Please describe this bug in as much detail as possible so we can replicate & debug this bug]

Can the LOGO element use dynamic data to call the ACF image field? I remember it was possible before.

Hi wildworm,
Thanks so much for your report, but what is the bug?

As far as I know, you could never use dynamic data for the image in the logo element. But it’s not a problem, because you can just use the image element instead :thinking:

Best regards,

Well, I know it’s okay to use picture elements. But I’m sure that the image of the logo element can be used with dynamic data before, which should not be an illusion.

Thank you.

Then show me and tell me with which version :slight_smile:

Yes, Version 1.5 has dynamic data, logo element.


Aaaaah I see! Sorry, you are absolutely right :slight_smile: Sometime in the last x versions it got lost (actually hidden, because it’s still there if you inspect the code) :smiley:

Yes, I’m glad you confirmed this issue. In fact, the question I want to ask is that the dynamic data function of the image field on the LOGO element does not work properly.

The dynamic data field for the logo element is back in Bricks 1.7.1, now available as a one-click update in your WordPress Dashboard.

Please let us know if you are still experiencing issues.

Best regards,

Yes, I see the field. However, my concern is that the dynamic data cannot properly display the logo image uploaded from the ACF field.

Where is the ACF field located? What location rules do you use for the field? If it’s not located on an ACF Options page for example (which is globally available), it can’t work.

Yes, I have defined an options page, and an IMG field was set up for the LOGO element to be called just like the other fields. However, while other fields such as Header Button can be displayed correctly, the LOGO image does not appear as intended. I have to open the Header template and click on the image element (no further modification needed) to display it properly. Moreover, when I choose a new LOGO image in the Options Page, it cannot be displayed properly again. Please identify this issue and fix the BUG urgently.

Furthermore, when I deleted the LOGO image on the Options Page, the LOGO still displayed. It seems that the dynamic data in the LOGO element is not updating automatically.

I cannot reproduce the issue. Would you be so kind as to send temporary login credentials and a link to this thread to using the email address you used during the purchase?

Hey, problem detected :robot: .
Will work seamlessly in the upcoming version :v:

Yeah! Thanks very much!

@timmse Hello, did this be fixed in the new version? I don’t see it in the changelog.

No task was created for this because it was a 10 second fix. Please test if it works for you, I can’t see a problem.

Yes, I tried it again, it works, thanks for your help.