SOLVED: Template not saved after a few saves

Bricks Version: 1.4.RC2
Browser: Chrome 101
OS: Windows
URL: any

I have a template for a single post with dynamic data and after afew saves, nothing is saved any more.

Try pressing cmd/ctrl+shift+s.

It says that it is saved but it doesn’t save it.

Hi Yannis,
Thanks for your report!

Can you be a bit more specific? What is not saving? Styles, Elements, Classes, everything?
Do you have some caching going on that probably affects the builder? If so, please disable it to see if it works then. Also, please disable your Plugins one after the other and see if the issue still exists.

Best regards,

It doesn’t save anything actually.
I have no caching, and when i close the page and i reopen it, nothing is saved, so it has nothing to do with caching.
Regarding the plugins, i have very few enabled, since it is a development site.
I can give you access if you like.

You got me thinking… something like this happened to me yesterday when I was editing a page. I tried to give a container a border and a background color for a test.
First, I set background color and it updated frontend. After that, I set a border and removed background color, I saved, but nothing changed on frontend, even if I refreshed the browser. In the builder, everything was correct.
Then I tried to change the letter in the heading, I saved, and the letter changed, the background color went away and the border showed up. So it was working.
Then I tried to set background color back, but it didn’t showed up until I changed one letter again.
After that it worked everytime, even If I tried the same steps again so I taught it is probably something on my end, but reading this… it might be somewhat related to your problem.

Hi Matej,

We are aware of your problem. It is related to the fact that certain actions were not recognized when assigning or removing styles. But this is something completely different than not saving at all.

@ysintos Ok, please send us login credentials and a link to this post to Please use the email address you used while purchasing Bricks. Thanks!

Best regards,

Oh, sorry. I thought it was related. But I’m happy that your are also aware of my issue.

Best regards,

Hi Yannis,
Thanks for the access data!

Except for the fact that some styles are sometimes not saved correctly (see above) I can not spot any problem :thinking:

Btw., If by 18 active plugins you mean “very few” I don’t want to know how many there are in an actual page :sweat_smile: :v:

Ok, shoot me hahahaha !!

I keep getting the same issue of not saving after a few saves…

It was probably my mistake. it saves, it only doesn’t refresh very soon on the frontpage.
So just please mark the thread as solved.

I’ve been running into this a lot with the RC, where the changes aren’t saved. This is with the front end open in one tab, and the builder in another and saving and not seeing the changes. Then if refreshing the builder, everything reverts to a previous save so the work is lost.

Can’t find a way to reliably recreate the issue to show it, it’s just something I keep bumping into occasionally.

This stopped happening after I turned off auto save in Bricks’ settings.

1 Like

Hey guys,
Thanks for letting us know!

We had a couple of issues with unsaved Changes in RC2 which should be fixed in the next release.
If you still have problems, please contact us!