SOLVED: Some of classes' styling not loading on front-end

Browser: Chrome 110
OS: macOS / Windows / Linux / etc.
URL: Link to a page that illustrates this issue
Video: Jam

Hi,

I ran up into an issue where some of classes’ styling don’t load on front-end. I recorded a video to better demonstrate the problem.

Petr

1 Like

Hi Petr,
Welcome to the forum and thanks so much for your report!

Can you please change your styles to inline styles (Bricks » Settings » Performance) and see if this fixes the problem? If so, you have invalid CSS somewhere that is sabotaging the creation of the external files.

The easiest way to find out where: copy the bricks-frontend-inline-css and bricks-frontend-inline-inline-css style tag into a code editor that supports CSS linting (such as VS Code) so that errors are displayed directly.

If this is not successful: Would you be so kind as to send temporary login credentials and a link to this thread to help@bricksbuilder.io using the email address you used during the purchase?

Best regards,
timmse

Hi timmse,

I’ve sent an email as the suggested solutions didn’t help.

Petr

Hi Petr, did you find a solution. I have the same issue

This is a message I’ve received from Bricks support team:

Your website encounter a very special weird issue which is related to the global class DB.
There is one empty array inside the global class DB causing the global class style to get incorrect index and so the styles are generated incorrectly. We can’t replicate the issue locally and I believe you wouldn’t too. As a workaround, I can apply a code temporary on your site to fix the corrupted DB and remove it afterward.

The issue appeared again and the temporary code had to be applied once more. I decided to stop generating classes using BEM generator from ACSS and start creating classes in normal bricks way. The problem hasen’t appeared since.

Funnily enough - similar issue.

A broken class was created and affected everything.

Using ACSS also. ACSS fixed it and thought that maybe pressing back on browser or too many builder windows opened at once.

Hey Petr,
Thanks for the update!

If you can clearly and reproducibly trace the problem back to the ACSS BEM generator, you should contact ACSS support so they can fix it. But as I said, only if you are really sure that this is the cause. We try to use the feature from time to time to see if this could be the cause. However, as it is a third-party feature, we can’t spend an endless amount of time on it :v: