SOLVED: Slider element doesn't load terms anymore

For some odd reason the terms do not load an stay with their internal naming. I can not select or change or add any terms to the slider element anymore. I copied it to different templates and new ones with no effect. Changed the browser, cleared cache but this thing doesn’t load any terms anymore. A prior state staging hasn’t this issue. When I copy the working slider from the staging to the live page this issue persists. I had to re-create that slider with the nestable slider element as a backup but I want that initial slider to work again. What is this?


Hi Mike,
Thanks so much for your report!

Could you please try re-downloading Bricks from and reinstalling the theme?

Please deactivate your plugins to identify the root cause if reinstalling the theme won’t fix the issue.

Best regards,

Yeah, well its the Live site with several customer orders per hour. I can not fiddle around with it. I will make a staging copy and test. Other input fields for instance like the query loop element are not affected by this behaviour.I get the following error in the dev cons. Nounce issue?

Failed to load resource: the server responded with a status of 500 ()

main.min.js?ver=1711070318:22 Object Objectaction: "bricks_get_terms_options"bricks-is-builder: 1nonce: "34319e2626"postId: "19861"postTypes: []taxonomy: Proxy(Array) {0: 'product_cat'}[[Prototype]]: Object 'error'

This has started once we added subcategories to the page. The slider functions as a category slider.

//Edit: So a new staging copy hasn’t this issue. I reported a while ago that Cloudlfare Waf flags Bricks but had no response. Cloudlfare Cache is bypassed for all staging pages. The Waf measures are reduced. Everything else is identical. Cloudflare is the only thing I can think that is different.

//Edit: So Cloudlfare logs that request:


but I had the rule set up correctly and it is setup to skip any any security measures for my ip.
So Cloudlfare doesn’t block it

Maybe not unimportant to note that every new slider element has this issue and not only that particular one. And this issue is happing for “terms” and all taxonomies. If I select “posts” for instance the dropdown field shows all available post. So the terms request is corrupted somehow.

Hi Mike,
I didn’t ask you to fiddle around, just re-upload the theme. This will take less than 5 seconds and will most likely fix your problem.

If it doesn’t, please send access data and a link to this thread to

As this is the Live page it is not “just” a simple task and need to be done carefully. Anyway I reinstalled Bricks and the issue is still the same. I send a message to

Solved with help from the Bricks support. Attribut Stock plugin was involved and they already offered a fix for that issue.

1 Like