SOLVED: Missing item in WPML manual , templates are not translateable by default like shown
The translation for the templates is not automaticly activated , you need to go to setting in WPML
Then scoll down to Post Types Translation and select on of the 2 translation options instead of Not translatable

Hi @Johan,

I have updated the academy article with a notice on how to enable translations for templates as it seems like it’s not reliably enabling it.