SOLVED IN 1.4: Styles not output after upgrade to 1.4RC

Bricks Version: 1.4RC2

I’ve got a majorly weird situation after upgrading at site from 1.4b to 1.4RC. Styles set at the ID or class level in the Bricks editor are not appearing in the front end.

Here’s an example, the page is

In the builder, this div is set to
height: 100vh
overflow: hidden;

This is set at the ID level (#brxe-enlwkb).

On the front end, none of those styles are output for #brxe-enlwkb

It also looks fine in the builder, totally different than on the front end.

I’ve tried clearing all caching (it’s Cloudflare full-page caching), setting CSS files location to both internal and external, regenerated CSS files multiple times, run the converter, viewing site while logged out and logged in, disabled other plugins…everything I can think of.

The only thing that happened between it working and not working was upgrading to 1.4RC2

Any idea how to fix this?

Hi Eric,
Thanks so much for your report!

We’re currently investigating an issue with unsaved changes in some scenarios, which may also be responsible for your problem.

I’ll get back to you as soon as I know more.

Best regards,

Hi @ainom,
Please try the new “CMD/CTRL + SHIFT + S” force save shortcut (not mentioned in the shortcut list yet) to see if the styles are saving correctly?

If that doesn’t work either, please send temporary login credentials to :v:
Thank you!

1 Like

I’m not OP, but just to report back to you, I had same problem right now. I pressed “CTRL - SHIFT - S” and it worked for me, refreshed perfectly on the frontend.


CMD+SHIFT+S did not work, so I am sending admin login credentials.

I should note that there are styles missing from every page (and header/footer templates), the ABout Me page was just provided as an example.

Hi Eric,
we probably found the root cause of the issue on the about page:

The custom CSS on the image is broken.

Wrong (not working)

@media only screen and (max-width: 479px) {
	root img {
    object-position: 30% 50%

Right (working)

@media only screen and (max-width: 479px) {
	root img {
    object-position: 30% 50%;

Best regards,

1 Like

Yep, that did it. But why did that final curly bracket get removed?

Unfortunately, I can’t tell you because I don’t know if it was gone before and if it still worked or got lost. The main thing is that it works now - and the Custom CSS indicator turned out to be helpful :slightly_smiling_face:

If the problem occurs again in one of the next updates, please let us know :love_you_gesture: