SOLVED IN 1.4: Page specific custom code issues

Bricks Version: 1.4RC2
Browser: Chrome
OS: Windows


I can’t get page specific CSS working with inline CSS option.
(It is working with external files.)
NOTE: CSS is OK inside the builder.

And I can’t get JS working either.
NOTE: Global custom code in Bricks settings is OK.


(Also tried JS without script tags.)

Can’t reproduce.

Both page-specific CSS and JS work fine for me w/ the inline CSS option.

Thanks @Sridhar, I’ll look deeper how I could break this.

Would you be so kind to tell me where you find your inline CSS in HTML source?
Is there a section in header CSS?
My CSS is nowhere.

I can just find the global custom CSS:


view-source:Test Page – Try Bricks – tf76cfe1

Looks fine for me as well :thinking:

Thanks, I think I reduced the perimeter of the issue…
Tested my CSS and JS on other pages, and it’s working :partying_face:

But why?
Well it seems to work ONLY on pages EXCLUDED from my single page template.

So, could there be something preventing inline PAGE CSS when using a page template?

Can’t reproduce.

I created a “Page” Template that applies to all static Pages except one specific Page (which is built with Bricks).

In the Page Template, I added custom CSS.

It loads on all static Pages except the specific Page as expected.

Thx for testing :slight_smile:
But it’s the other way around, CSS on a page, not in template.

CSS works OK in template, by the way :wink:

So per my gif above, it is “Sample Page”. Correct?

If so, I added custom CSS by editing Sample Page with Bricks and added custom CSS inside it. It loads fine both in the editor and on the front end.

We’re getting closer :wink:
My english may be limited with technical stuff…

It is actually working on excluded pages, but can you add CSS on a page NOT excluded?
This the broken case.

Hey @yankiara ,
I guess I was able to reproduce the issue using inline styles. Seems like page » custom code » custom CSS (on a page) isn’t showing (on frontend) when using inline styles - within the page template it shows.

Can you please switch to external files and see, If that solves the issue?

1 Like

Yes, as I explained in my original post, it is OK with external files.

The issue is:

  • inline page specific CSS and JS
  • page using a page template
1 Like

Yes, can confirm the issue with inline styles setting. It only works in the editor.

Ok, Thank you guys. Confirmed and added to the bug tracker!


Hi @timmse again,

It seems the issue is not limited to custom code.

I have the same behaviour with Pagination element and a custom CPT query on a static page:

  • If I exlude the page from template, pagination is OK.
  • If I don’t exclude, pagination doesn’t appear.
1 Like

Hi Yan,
Thank you! Confirmed and added to the bug tracker as well.

Best regards,

1 Like