SOLVED: Image Gallery External links do not work

Bricks Version: 1.4
Browser: FF 101.0.1 & Chrome 102.0.5005.115
OS: Windows
URL: Download Your Free Content |

This page uses an image gallery with external custom links set to download a file.

  • The images do not link
  • The link text does not show and therefore does not link
  • Firebug shows that not link is being inserted.

May be something I’ve missed but seems like a bug.

Hi Chaten,
Thank you for your report!

This is a Gutenberg gallery, right? Works fine for me… can you maybe record a short screencast and show/explain how you create your gallery?

Since we are not changing anything in the Gutenberg content, I don’t think this is a Bricks bug.

Best regards,

1 Like

Hi timmse, I’m sending you vid through a PM if that’s okay.

Hey Chaten,
Thanks a lot for the video!

The gallery on the frontend is not the Bricks gallery, it’s a Gutenberg Gallery. I can see that from the generated HTML:


The page or post isn’t rendered as Bricks content but as Gutenberg content.

Best regards,

1 Like

Ah okay, thank you very much. My mistake. Your help is appreciated.

I’ve looked into this again and its a bit odd because the page was created with Bricks and it’s also rendering with bricks. I also just resaved it and created the gallery again within bricks but its still outputting Gutenberg.

To solve I’m guessing I have to create the gallery manually within Bricks, image by image, rather than use the gallery feature.

There is an option in the admin bar to change the rendering mode - Bricks or Gutenberg. Check what you have ticked.

It’s set to bricks. Wordpress admin>pages> also has the page labelled with bricks.

Hey, can you possibly have “Save Bricks Data As Gutenberg Data” enabled? This could be the reason that your content is converted :thinking:

@timmse Even if he have ticked that - Bricks template should override gutenberg right?

I did have “Save Bricks Data As Gutenberg Data” enabled. I disabled it and then tried saving the page again but got the same result (no links working). I tried adding in another gallery into the same page via bricks to see what happens. The gallery is inserted in the builder but didn’t show on the front end.

I then enabled “Save Bricks Data As Gutenberg Data” and the new 2nd test gallery displayed , however both galleries still don’t have links associated with it and both are still Gutenberg.

Also disabled caching and modification just in case but that made no difference either. An odd one!
I’ll do some more testing later today and see if anything new comes about. :thinking:

Hey Chaten,
Did you manage to solve the problem? If not, please send us credentials and a link to this thread to with the email address you used to purchase Bricks.

Best regards,

Hi Timmse, I’ve just tested it now and think I have solved it.

This page was using a bricks template that I created. The page template pulls in post content to populate the page. If I unassign the template from the page then the image gallery works correctly. When I assign the template to the page, I’m guessing that the image gallery changes to Gutenberg because its pulling in data from WP. Therefore it stops the bricks version from rendering fully.

The issue in the end was that I was mixing Wordpress rendering and bricks rendering without realising it.

Sorry if I wasted everyone’s time. :zipper_mouth_face: but the mystery has been solved.

1 Like