Solved: How to remove the Horizontal scrollbar?

Hello Bricks Builder Gurus!

Version: Bricks Builder 1.7
Browser: Edge latest

I’m having a problem with the website looking full width in desktop view.

By setting a width of 100% or 100vw for the sections (header, content section, footer), the scroll bar suddenly appeared at the bottom and the page can be scrolled horizontally. This was not the case before, so I think that I stopped something or it was stopped.

I would appreciate it if someone could take a look at the site and give me some advice on what to set up. I hope this was not a software bug, but my carelessness.

In general: what is the difference between 100% and 100vw? Which should be used for the outermost element (section)?

Thanks in advance


No need to set a width for the sections, they’ll default to 100% width.

As @wplit already stated there is no need to set a width on the section element. Using 100vw is problematic since it results in horizontal scrolling (depending on the OS and browser used) most of the time.

See 100vw and the horizontal overflow you probably didn’t know about - Jonnie Hallman (@destroytoday).

Thank you! Deleting all the width settings and only leaving the default 100% ( pale gray) in the Max width, everithing is wordking good.

Thank you very much for the help!


1 Like