SOLVED: Hide if 'page' ID not working (OR condition)

Or rather, show if not page. Using != rule to hide an element on pages. Thought it was working fine, until I added another page ID to the contidions list and now I can’t figure out what’s wrong.

Want to hide dark button on these pages:
https://emagazines.tempurl.host
https://emagazines.tempurl.host/contact

Using:
image

and even:
image

I thought that would do the trick…

Version: 1.5.7
Cleared cache etc

Nope. Set those parameters. Still getting both buttons: Contact – eMagazines

Dark Blue is default. I’m trying to hide it on specific pages like the Home Page and Contact Page. Because the Light Blue Button is conditional only to Home & Contact (set by post ID)

Hi Ace,
Thanks so much for your report!

I was able to reproduce the issue and added it to our bug tracker.
If I use only one of the two conditions, it works as expected.

Best regards,
timmse

Sure, so that’s what I did originally. @timmse

OK, let’s simply this : I have two buttons, one dark one light blue. The light blue should only show up on two pages, as set by page ID, and the dark blue should hide on those same page IDs.

These are the settings for Light blue (show ONLY on those pages)

These are the settings for the Dark blue (show everywhere BUT those pages)

@aces While there is a bug with the “OR” condition that we’ll fix in 1.6 stable, I wouldn’t actually use the OR relation in your case.

To avoid rendering your dark button on those two pages, try putting both “!=” conditions in the same condition group.

So there is an AND relation like this:

Post ID != 2952 AND Post ID != 2953

That should already work.

1 Like

OOhhh… that’s what was meant… ok, thank you, it worked!!

Is this related, or am I just setting it incorrectly?

I’m trying to show the container with text with blue background when there’s no image, and the container with image when there is an image.
Right now with these settings, they both show up (aka, cont w/ image back shows up all the time, but blue hides as it should)

w/ image: Apple News+ Support – eMagazines
image - this one populates every time

no image=blue back: Analytics & Reporting – eMagazines - this loads as it should - loads when there’s no image and doesn’t when there is
image

Hey Ace,
Bricks 1.6 (Beta 2) contains a fix for the “OR” condition problem.

You can download it manually in your account:
https://bricksbuilder.io/account/?v=1.6-beta2

Unfortunately; I cannot visit your site:

Best regards,
timmse