SOLVED: Happy Files compatibility

I know that there is a workaround for this issue, but it would be nice if you can squeeze it in the next update. Thanks. :smiley:


Yes, I also bought Happy Files. Hope they don’t abandon it. Somebody told me about a files plugin and when I suggested Happy Files… they hesitated and told me that “those guys are not maintaining that anymore, because they are building bricks”.

I still use it and would hope he is wrong and that Happy Files will still be maintained going forward.

Solved in 1.3.2 :clap: :clap: :clap:

Hi, How is it solved in 1.32?
Trying to select an image just lets you choose from a single page of Media File images with no regard for the existing HappyFiles organization ( folder structure ).

Looks like “hit and miss” still. Sometimes I have to reload canvas to make it work as it should.

Just miss for me. Tried reloading canvas also creating new pages. Not seeing any sign of the Happyfiles folder structure so just faced with a huge list of unorganised images.

You should send an email to support. That is the best way to solve problems.

Yep I will. But as this was under Feature requests I wasn’t sure if it has now been added, and therefore a bug, or if it was still waiting to be implemented.

Good news. This will be fixed in HappyFiles 1.6 ( No eta ).

But there is a workaround if you can’t wait.

In the meantime you can change line 33 in wp-content/plugins/happyfiles-pro/includes/helpers.php from

isset( $_GET[‘bricksbuilder’] ) ||

isset( $_GET[‘bricks’] ) ||

1 Like

Hi, I’m replying to this old post because now, 3 months later, I’m having the same issue.
I’m using HappyFiles 1.5.1 and Bricks 1.3.5.

Should I use again this old workaround?


Hi, I’m using Bricks 1.3.5 and Happyfiles 1.6beta as well as Bricks 1.3.5 with Happy Files 1.5.1 and both are working perfectly. I did make the work around change to the 1.5.1 site but not the 1.6 beta. So I am assuming that all has been fixed now.

1 Like

Hi @alanj, I confirm that with Bricks 1.3.5 and HappyFiles 1.5.1 your workaround is working good.

Thanks again!