SOLVED: Dynamic data afc youtobe video does not display correctly

Browser: Version 119.0.6045.159 (Official Build) (arm64)
OS: macOS
URL: https://oilteck.com/shop/cars-motor-oil/vp-pro-grade-sae-5w30-full-synthetic-oil-racing-vp-2727/
Screenshot:



Shows when dynamic data is empty but needs to show like this

Hi @turquoise,

Not sure if I understand you correctly but you have “controls” set to disabled:

And now its enable still the same



and yes I cleared the cache

Unfortunately, I’m still unable to replicate this locally. Btw can you help me understand why you’re setting the thumbnail to the video URL?

Maybe if you can also share the YT video URL I can also try replicating it using the same URL.


https://www.youtube.com/watch?v=cbz__ztzYs0&t=2s looks good on my end:

Can you try disabling all plugins?

Yes tested but it’s not help. And the conflict looks like is in bricks and ACF.
If I add simple a video it shows correctly but if use ACF it shows as I sent in the example.
I do show when I use the dynamic data that is added to the product as a video.

What’s the ACF field type you’re using? I tried URL and it worked on my end





Changet to URL the looks the same like when use oEmbed

Unfortunately, I’m still unable to replicate it locally using the same URL & ACF field.

If you can share temporary admin access to help@bricksbuilder.io with a link to this forum thread we can try to investigate it on your setup.

I just sent you an email.

This first is how it needs to be and second is how I got now.


The test link is:

Hi @turquoise,

Thank you for sharing access. I found the bug here:

The video element was initially configured with “Vimeo” as the source with a preview image, which led to the bug you saw. I removed the preview image & set the source as “Dynamic Data” again so now controls should render as expected.

I have also added this to our internal bug tracker.

1 Like

Thank you for sorting this out!

1 Like

We’ve fixed this issue in Bricks 1.9.5, now available as a one-click update in your WordPress Dashboard.

Changelog: Bricks 1.9.5 Changelog – Bricks
Please let us know if you are still experiencing issues.