SOLVED: Bug in Slider widget height

Bricks Version: 1.5.7
Browser: Chrome
OS: Windows

Hi bricks team!

If we add a slider widget, its height is 50vh by default. I try to set the height lower than 50vh but it doesn’t change. But I can increase it.
But if we add the nestable slider widget, we can make its height lower than 50vh and there is no problem with this widget.

This problem exists especially in mobile device for slider widgets. In mobile, the height of the slider widget is very unusual and we cannot reduce its height.

In general, the problem is that in the slider widget, the height does not go below 50vh.

Hi Hosein,
Thanks so much for your report!

I am not quite sure if this is a bug or if the min-height label is just misleading, but I have added it to the bug tracker.

The min-height setting only refers to the slide, not the slider itself. If you also set the min-height in the style tab to e.g. min-height 25vh, it works as expected.

Best regards,

1 Like

Hey Timmse,

This is something I’ve noticed as well. I almost always have to set the height to auto because if the browser height is too small, it crops my content off. As you can see, there’s supposed to be a button in my slider too but the S is so big it just pushes the button out of the slider due to the slider content being larger than 50% of the browser height.

I think all we’re suggesting is a more sensible default here. Such as auto, or initial.

There is the same problem with simple Slider.
Setting the min-height, has no result.
Min-height is always 50vh.

1 Like

yes, It works fine in nestable slider, but there is this problem in Slider.

Hoseins report is about the regular, non-nestable, slider :wink:

I understand your problem @cmstew , but the default setting works fine for a slider that only contains images, for example. Therefore it is difficult/impossible to set a default that always works in every case.

1 Like

That’s fair and I realize that now. Sorry for going off topic. :sweat_smile:

1 Like

Hey Hosein,
Bricks 1.6 (Beta 2) contains a fix for this problem.

You can download it manually in your account:

Best regards,

1 Like