SOLVED: Bricks classes lost


What happened to Kevin on that tutorial and what @sleeplesskxng seems to explain is not exactly what happened to me, but maybe it comes from the same issue.

In my case, all the classes created, in every element and in every page, disappeared (with apparently no reason). Then, in each element where there should be a custom class, there only was an .undefined class.

That broke the site completely, and the only way I managed to solve it was going through every page and re-adding each class. After adding a class that existed there before, all the properties of that class were applied properly. It is not that the classes were completely erased, just that they were unassigned to the element they were assigned before “the issue” occurred.

Hope it helps investigate this bug because it’s a huge one! It happened to me on a live client site that was already finished. I was required to make just a small text change on a template and… BAM! :fearful:


Hi Mustafa,
Welcome to the forum.

Your issue is completely different because your classes are still there :slight_smile:

Would you be so kind as to send temporary login credentials and a link to this thread to using the email address you used during the purchase?

Best regards,

same issue today.

I have made a minor change in a page and all my classes are disappeared !

it happened during the last revision a few minutes before the scheduled launch time of the site! it was a tragedy. We are still rebuilding all classes one by one :sob:
(Restarting from the backup meant losing all content changes made “on the fly” with the client, which would have been much worse)

(Bricks Version: 1.5.7 - Litespeed - Metabox AIO)

1 Like

Hey Lapo,
Sorry to hear this, but we still need a way to reproduce the problem. Especially when reproducing the bug reports, I make a lot of minor changes, but so far I have not encountered this problem once. Otherwise, we would have had a starting point long ago…

Hi @timmse , thanks for your reply!
I understand the need for more precise indications, but I honestly don’t know how to reproduce the exact problem as I was making numerous changes at the same time and only at the end, in the frontend, did I notice the problem.
Surely (following what was indicated by another user in another post of this forum) I have used the “undo” function several times (even if I had used it other times in the past both on this site and on others without problems… it seems occur randomly). I don’t know if this will help you.

Bricks 1.6-beta2

This might help.

See video: Recording #37

This is with the logo button set to open up the preview of the page.

  1. Add a custom class to 3 divs.
  2. Click the logo button for preview.
  3. Use the Browser’s Back Button to return to builder.

The custom classes are now missing!

The classes are still in the page though. If we manually hit save, the classes are still in the file, nothing is changed.

However, if we add an element and click save, we effectively deleted the custom classes.

This Preview → Back Button behavior looks strange indeed. Not sure though if this is related to classes getting lost. But maybe you wanna have a look what’s going wrong here, @timmse:

  1. Create an element (e.g. a section)
  2. Apply a class to the section for better visibility via Style > CSS > CSS classes (I created this class via Bricks > Settings > Custom code)
  3. Add a heading to have some context
  4. Save the page
  5. Click the Bricks button to go to the preview (it is set to not open in a new tab)
  6. Check the page in the frontend → looks correct!
  7. Use the browser’s back button to get back into Bricks builder
  8. Check the builder → the section that was added before is missing
  9. BUT: Using the browser’s reload button at this point reloads the builder and brings back the section that was added before

Demo: Video uploaded to CleanShot Cloud

1 Like

@aslotta If you do anything that would potentially change the state of the page in your step #8 and then save. It will delete changes you made to the page. This is the same behavior if you have 2 tabs open. If you work on the page in one tab and then open the page in the builder in another tab and edit it. If you save again in first tab, it will not revert your changes, but if you do anything in the first tab to potential change the state (toggle a setting on and off) and then save, it will delete any changes you made in the second tab. This is good behavior unless you forget and start editing again in the first tab and save.

@aslotta Also, if you turn of autosave and make changes to a page in one tab, then change it in a second tab, save in second tab and close the tab. Later if you view the first tab and forget what you did and hit the save button, it will wipe out all the changes you made in the first tab.

Additionally, if you are editing a page in the builder:

  1. Click the Preview Button on the right
  2. Click View On Frontend and a new tab opens with a preview.
  3. Click Edit With Bricks on the WP Admin Toolbar.
  4. Now, in the new tab, make a change to the page.
  5. Click the Preview Button in the new tab.
  6. Click View On Frontend in the new tab. Notice that the preview opens up in the same tab and not in a new tab.
  7. Click the Browser Back button.

The change you made is now missing, just like if you used the logo button for preview as described in WAIT: Bricks classes lost - #21 by macksix

Hey @macksix & @aslotta ,
Thanks for providing the steps, but isn’t this a different issue? This report is about losing all classes, not losing a section or elements on the canvas when going back and forth :thinking:

Of course, I will go through the steps, but I can’t expect all my classes to be deleted, can I?

@macksix You have already mentioned the same steps here, where they are more appropriate than in this thread, I think.

@timmse This is about losing all custom classes on a page that I am describing. I am not sure I understand what losing all classes mean. Losing classes auto assigned by Bricks?

“Of course, I will go through the steps, but I can’t expect all my classes to be deleted, can I?”

All classes no, but you can lose all custom classes on a page for sure if you leave a tab open with the page in state that has no custom classes and then in second tab you add all of your custom classes, save, close tab and then later hit the save button the first tab. It will wipe them all out.

Same if you use back button to go to editor and load a page with no classes, add any setting or toggle a button on and off, then save. All your custom classes for that page disappears.

It could be out of place for the trouble described, but I thought is might give a hint for all classes disappearing. So far I can’t figure out a way to make all classes disappear. :slight_smile:

All good, maybe I’m mixing other reports about “losing classes”… there are some of them where classes were removed from an element (as you described), and others where all classes are completely deleted from the class list.

At least with your steps, we have a point to start with :+1:

So, when I follow your steps (@macksix @aslotta ), I lose the elements - not the classes on the elements. This is the problem that was described here and that I can reproduce thanks to your steps.:

It is quite possible that the same problem removes classes of elements, but as I said, I still cannot reproduce it. We are trying to fix the other problem as soon as possible, and with a bit of luck, this problem will be solved as well. If you have any other tips that could contribute to the solution, please let us know :slight_smile:

1 Like

Hi all

Thanks for continuing this discussion. When I had the original issue I can confirm no other tab was open in my browser in any other state.

Due to how catastrophic this bug could be to a build I’ve suspended all use of Bricks until resolved but am following the topic.


I can confirm that after reloading the css reappeared. I am on the version 1.6

We ran last week into this problem too.
Added custom classes. A hour later they were gone.
I will try to check my server too (nginx). Maybe there is a caching problem.
But behaviour itself ist very strange and extremly bad for the trust in daily use.
We added custom classes now in wpcodebox. That saves the classes but don’t solve that the element in the builder lose the added class.

(Using 1.5.7)


I just lost all my custom classes as well! I did have the preview mode window open. Trying to retrieve the classes in revisions does not help. Is there any way to retrieve them?


@m910 I helped someone with this issue the other day so I might be able to help you get the classes back.

Could you go into your wp_options table and search for the option_key “bricks_global_classes” and paste the option_value onto Then click the unserialize button and post the url here.


I am also surprised that there is no feedback from the Bricks team for such a long time and though it’s an extremely urgent and important issue. But I’m even more surprised that Bricks team doesn’t just start to roughly narrow down the reason(s) by simply asking us users and trying to identify patterns that way. Oxygen for example did a survey in their Facebook group to find the reasons why the builder has been loading so slowly.

Concerning the loss of classes, these (and a ton of other similar questions) could be asked to narrow down the reasons:

  • On which hosting environments were the websites running where class loss occurred (exact info needed for detailed analysis)?
  • Which actions have been performed inside/outside the Bricks Editor before the class loss?
  • Is displaying dynamic data enabled/disabled in the builder?
  • What has the DOM size of pages been which have been worked before the class loss?
  • Which plugins are installed?
  • … and several other similar questions …

Can common culprits (or group of culprits) be identified based on analysis of above given answers?