SOLVED: Archive with pagination: Disable query merge doesn't work

Guys, I set up a category list.

I configured the template conditions to appear in terms and tags.

Problem. When switching pages via the pagination link, the list of categories disappears. Is it a bricks bug? But {term_name} is not rendering in category archive;

someone with the same problem?
[Please describe this bug in as much detail as possible so we can replicate & debug this bug]

link média in group face bricks

Hi Hermes,
Thanks so much for your report, and welcome to the forum!

It is a known problem we’re currently working on. The queries are getting merged and currently, there is no “Disable query merge” setting for the terms loop, but we’ll add it in 1.7.1 :v:

Best regards,

1 Like

Thanks for answering.

Loving the bricks.

When does the new version come out? :smiley:

Hello, about this bug, has it been fixed in the next version?

Hello Hermez,

Releases are roughly every two weeks. Keep an eye on Changelog – Bricks and you’ll know when and if it gets fixed. :wink:

Hello, in this new update this error has been fixed?

Did you check the changelog? I think this is what you’re looking for. A short feedback if everything works as expected would certainly help the developers. :slight_smile:

Hi guys,
We’ve fixed this bug in Bricks 1.7.1, now available as a one-click update in your WordPress Dashboard.

Please let us know if you are still experiencing issues.

Best regards,

Hello, see the error happening. access the link.

is updated to the new version
see Blog - Desconto na Conta de Luz

Did you enable the “Disable query merge” option in the term loop?

Yes, I activated. See attached image.

Please send me access data (via PM or email to

sent to the email provided

Hi @hermez

Thanks for the login.

I found that you edited the wrong template.

You do have an archive template, and you disabled the query merge there.

However, the Blog page itself didn’t use that template because you edited it with Bricks.

Inside this blog page, you didn’t disable query merge, and this makes you think the Disable query merge doesn’t work.

PS: You should use the Archive template and apply an additional condition to Individual > Blog (Page), to avoid maintaining redundant templates.
Reference: Known issues – Bricks Academy

Hope this helps.


1 Like

Solved, thank you!!!