SOLVED: Accordion expand transition doesn't work the first time with expand first item option

Bricks Version: 1.5b
Browser: Chrome
OS: Windows


When using expand first item option, accordion expand transition doesn’t work on the FIRST click (no transition).

(EDIT: Nothing to do with template location or inline CSS.)

Hi Yan,
Thanks so much for your report!

I am not able to reproduce the issue with 1.5beta. How did you insert the section template? Directly, via template element or shortcode? Would you be so kind as to test it again with 1.5beta ?

Best regards,

Same with 1.5beta, when template is inserted or using template element.

And same behaviour inside the builder or on frontend.

I’m still not able to reproduce it with inline styles and the default accordion :thinking:

Do you have any additional settings on the Accordion or does this happen in general, with a “pristine” Accordion?

After many tests, it turns out it is the expand first item option which breaks the first transition.

(It has nothing to do with template location or inline CSS, sorry for misleading! → EDITED)

Ok, now we have a small but real problem :slight_smile:
I have added it to the bug tracker :v:


Just a reminder :wink:

1 Like

WIP still means the same as it did back then :wink:

Is there any way to fix this quickly with CSS? I have a site I am working on and I need it to work.

1 Like

It’s a long delay for a bug fix and no updates from Bricks team since July, so it’s a fair ask from @yankiara for an update. We’re all aware of what WIP means but it isn’t like it’s impossible to be forgotten about or missed after so much time has passed. :wink:

Surprised this hasn’t been fixed in so many months now. Hoping it will be addressed soon.

This is still a problem in 1.8-beta2. I don’t know how to fix it myself.

just checking back on this for an update? bump.

Hey @yankiara,

it’s been some time but we’ve fixed this issue in the meantime. :slight_smile:

Please let us know if you are still experiencing issues.