SOLVED: 1.8beta3 breaks ACF repeater output

Browser: Chrome 110
OS: macOS / Windows / Linux / etc.
URL: Link to a page that illustrates this issue
Video: Short screen recording that illustrates this issue (free tools: or

The food menu, at least the dynamic parts, simply disappeared.

Hi Joe,
Thanks so much for your report!

We need some more information on how to reproduce the issue. E.g. the repeater setup in general, which field types are you using, etc…

Would you be so kind as to provide either detailed steps or a screencast using or showing and explaining what’s going on?

Best regards,

Well, no idea but it’s literally what I said. No dynamic data showing in the food menu on the page. Just blank, what do you need me to show? I don’t mind, but not sure what to add to this.

Neither do the opening hours in the footer, which are also ACF driven. They are all fine in 1.8beta2 btw…

Not repeater related, but how beautiful is your site! :heart_eyes:
Good work on this one!

1 Like

Thank you, sir.

It’s one of the 3 styles I’m creating for hospitality businesses. People can base their personal site on these - kind of - halfway templates. The idea is EVERYTHING is adjustable within seconds, so the food menu, images, opening hours, FAQ, calender etc, and people cannot touch anything else.

Like this:

I totally need that for a client of mine who just opened a bagel shop! Thank you for your inspiration and this image here! Just curious on what is on the text blocks content / page?

Haven’t used that yet. But the idea is to use flexible content for the “rest” of the content apart from CPT type content. That way there is no reason whatsoever to touch anything website related.

Tip: use ACF options pages to create that menu and to use repeaters. Repeaters won’t work in CPT’s. At least they don’t display on the front end. So use options pages. Easy Google of you

If you have more questions, I’m Joe Kns in the FB group. Feel free to shoot me a message. Kinda getting offtopic here :stuck_out_tongue:

Please send us access data to using the email address you used to buy Bricks, so we can take a look at the requested details ourselves.

1 Like

Sent. Hope it helps. There was no change with the release of 1.8 today.

Same problem even on final 1.8 release :roll_eyes:

I have the same problem. Repeater in options pages not displaying the ACF custom fields.



Just one level of repeater fields.

Hey guys,
Unfortunately, we just received the access data today and are currently looking into the problem. We will get back to you as soon as we have news :v:

Can I see the site? Curious now how you went about it.

No problem, sure it will be solved soon.

Hi @Joe ,

Thanks for the login details.
I just applied a potential fix on your website, can you help to check it?

Hi @Loic .

Is it possible to provide a temp admin access for us via email? (
Would like to check if you encounter exactly the same issue as Joey.


1 Like

@itchycode Everything seems to be in order at first glance. If this fixes it, do I just wait for the next update, do I need to remove code later, etc?

Related. Same issue with JetEngine linstings (which are repeaters). They just don’t work. Already reported as a bug a couple of days ago. Happened with beta 3 and with v1.8 already launched.

Sent. I reply to the email directly.


I probably still want to buy your design. Mine is a 1 hour temporary build ! Still not visually balanced.

Will send you the link later :sweat_smile: