SOLVED - 1.4 RC - WooCommerce Empty Cart Template Doesn't Show up

Bricks Version: 1.4 RC
Browser: Chrome 90
OS: Windows
URL: - Bricks 1.4

So I have built a custom cart template, which works just fine, but I also built a custom Empty Cart template with the same conditions (Individual - Cart), and when I empty the cart or go to the cart page when it’s empty I don’t see the Empty Cart template. Just the cart template with no products in the products table.

I also tried incognito mode and same results.

Hello @alani

We found the root cause for this issue.

Please check if you have disabled the default templates in the Bricks > Settings > Templates.

If so, as a possible workaround, turn off that option (enable default templates). We’ll provide a fix in the coming Bricks release so you may be able to turn that on again, while still being able to use the WooCommerce template parts.

Hi @luistinygod

Thank you for getting back on this, I have followed your instructions, and still the same thing, doesn’t matter what I do, the empty cart template never shows up.

I’m using 1.4 RC2

Hello @alani

Thank your for letting us know. Could you please grant us temporary access to your WordPress dashboard? If so, please send us one email to mentioning this forum post.

Thank you

@luistinygod Done, Thanks!

Hello @alani

Thank you for sending the login credentials over email. I checked the issue and I already replied to you.

As explained, the Cart & Empty Cart templates do not work if you set Template Conditions in these templates. We’ve removed the possibility to set any condition on these template types to prevent future issues. We also added a note to the Bricks Academy article about this.

These templates are used inside the WooCommerce Cart shortcode logic and they do not support template conditions (they are automatically rendered on the correct page) .

A final note, the same is valid for the Checkout template parts.