Problems with editor and Cloudflare

Bricks Version: 1.5beta &
Browser: Chrome 103.0.5060.114
OS: Windows 11 Client/Cloudlinux Server

On Cloudflare reverse proxy the Bricks editor has problems loading all the images and it pegs my entry processes at 20 and I have tried at 40 and it is pegging at 40 too and causing EP faults.

I put in a rule to disable cache, performance and security for, but the problem still persists. I put clouflare in developer mode and it is supposed to bypass the cache and the problem still persists.

The only way it will work is to completely disable the proxy in the DNS zone.

I went as far as creating a new Cloudflare account just for that domain to see if there was any difference. There are none.

I don’t know why it is not working. :slight_smile:

I can give login for Cpanel, Wordpress and Cloudflare if someone would like to take a look. This is a bare metal server I host some clients on.


I am using Cloudflare with Bricks. My web server is Nginx. I have not noticed any issue or error.

Is rocket loader disabled? It’s known to create issues. Have you tried purging all cache at cloudflare and on server? You should also check the request headers in network tab while loading the Bricks editor and if any errors in the console log.

Only issue I had with my setup was that Bricks was taking long to query google font requests for reason unknown. Disabling Google fonts from Bricks settings reduced the server response time to under 400ms.

Yeah, rocket loader is disabled.

I have no cache on server, but yeah, I purged cloudflare cache a lot while testing this.

Request headers and console is good until it pegs the entry processes on the server and then it starts giving a bunch of these in network:

1. Request URL:

2. Request Method:


3. Status Code:


4. Remote Address:


5. Referrer Policy:


The consol gives a bunch of these:

POST 508     iframe.min.js?ver=1657746792:1      

Error     iframe.min.js?ver=1657746792:1 
    at iframe.min.js?ver=1657746792:1:354435 {action: 'bricks_get_element_html', element: Proxy, nonce: 'fd18231e2f', postId: '9'}action: "bricks_get_element_html"element: Proxy {id: 'bwrhgk', name: 'image', parent: 'qkqtct', children: Array(0), settings: {…}}nonce: "fd18231e2f"postId: "9"[[Prototype]]: Object undefined

Hi David

Just another couple of things to check:

Is your system information in green (inside bricks settings)
Do you have iframes embeds disabled inside bricks settings
What method are you using for rendering elements (AJAX or REST) again inside Bricks settings

Also, do you have any other custom security rules set inside CF?

My system information is green.
Iframes embeds are disabled.
Using REST to render elements.
I have no custom security settings in CF.

I have 2 filters in cloud flare to disable cache, performance and security:* 

Neither make any difference.
Putting cloudflare into developer mode makes no difference.

I checked your site to have a look at the console errors, but they were not there for me.
However, based on your image and the errors relating to embeds and element renders, try enabling embeds & changing render elements from REST back to AJAX

If that does not have any luck, one of the dev team will be a long shortly to help, no doubt

The console errors are only when loading the bricks editor, otherwise it is fine on the frontend.
Changing settings to enable embeds and using AJAX rendering makes no difference.

1 Like

Is there anyone who can login and take a look at this? HiVelocity tech support says it is software, but I am not saying they are right, I just can’t get any help from them and I am unsure what to do at this point to find the cause.

On my other server, I have CentOS 7 with no resource limits and the same installation (now v1.5 RC on both of these test sites). The other server shows the images loading slowely when the editor is enabled with cloudflare reverse proxy enabled.

Some of the images load fast and the others take a bit to load. It looks as though it finishes because there is no entry process limits. The process to load the images runs slow though.

This is 2 different servers with the same installation and same test page and there is no doubt a problem with the editor loading images with Cloudflare enabled. Even with rules to bypass cache, performance and security. Also with Cloudflare Development mode on that bypasses the cache.

The only way to stop the slow is to completely disable the reverse proxy.

I also tried this on a different PC and also tried tethering my 4G from my phone to use a different Internet connection and I see the same problem in both cases.

Now that I entered the rule “” on the other server, I see no slowness now. But that rule does nothing for me on the first server with Cloudlinux.