NO BUG: Woocommerce checkout page notice problem

Browser: Firefox 120.0.1
OS: Windows

So I have checked the “Enable Bricks Woocommerce Notice Element” and it seems to work on my cart page but when I change things in my cart and then continue to the checkout page it looks like it is carrying over a notice (for example that is given when you remove an item from cart, see video).

Also when I want to checkout without filling in my details it continues to give an error notice, even though I enabled the Bricks Woocommerce Notice Element & have not set a notice element on the checkout template page (see last part of video).

Video: Loom | Free Screen & Video Recording Software | Loom

Hi Nielzsche,
Thanks so much for your report.

Unfortunately, I cannot reproduce the issue. Would you be so kind as to send temporary login credentials and a link to this thread to using the email address you used during the purchase?

Best regards,

Thx for the reply. I’ve sent the e-mail.

Hi Niels,
None of your cart, empty cart or checkout templates had the notice element included, which is necessary (see screenshot):

I have now inserted it into the three templates and can no longer see a problem. Or am I missing something?

Leaving the notice elements out was on purpose. I might still add them for certain pages but I don’t want to add them on the checkout page as I don’t want any notices to show there. I was under the assumption that turning on that option in the settings and then leaving out a notice element would completely leave out any notices but as you can see they still appear (at least on the checkout page, the cart page seems to leave them out).

Rereading my original post now and I didn’t really make it clear that I was actually aiming to leave out all notices on the checkout page, sorry for that.

Aaaah now I got it, sorry.

The notices are of course still showing and are simply replaced by the notice element if it is present. The setting would then have to be called “Disable all WooCommerce notices” to achieve what you want :smiley:

If you don’t want to show a single notice within the checkout at all:

.woocommerce-checkout .woocommerce-NoticeGroup.woocommerce-NoticeGroup-checkout {
  display: none;

Yeah… you got a point there haha :sweat_smile:
Thx for the help!

1 Like