NO BUG: V1.8 Beta 3: JetEngine listings not working on frontend

Browser: Chrome 110
OS: macOS / Windows / Linux / etc.
URL: Link to a page that illustrates this issue
Video: Short screen recording that illustrates this issue (free tools: or

While working in this beta version listings are not working on frontend. Once I rollback to v1.73 everything is going fine. That’s what I’ve found about JetEngine until now.

Hey Leo,

thanks for your report.

Would you be so kind as to provide us with a screencast demonstrating the exact issue you have? That’d help a lot understanding and – if applicable – reproducing it.



Here is a video… I try to explain this… sorry about my English… not my first language :sweat_smile:.

Hey Leo,

thanks a lot for the video. Your English is perfectly fine. :smiling_face: I will have a look at it and get back to you.



1 Like

Any news on this? I’ve seen several complaints about problems with repeaters, loops, and in my case, listing, all of these when upgrading to v1.8.

Some update on this issue? Please, I’d appreciate your support.


I am also experiencing the exact same problem with v1.8 and Listings. I hope we get some support soon. Bricks + JetEngine are amazing together, so hopefully the Bricks team can fix this.

1 Like

Yeah. 1.8.1 Release still has this issue. Last support contact was 9 days ago.

Hi @LeoG ,

Sorry that we might miss out on this thread.

For your information, the JetEngine Listing feature is provided by JetEngine plugin.

I tried to replicate this locally (JetEngine v, and this should be the error code if you enable WP_DEBUG

Fatal error: Uncaught Error: Call to undefined method Jet_Engine\Bricks_Views\Listing\Assets::generate_inline_css_global_classes()

The error was pointing to the JetEngine plugin file and I can see it is trying to use Bricks function (\Bricks\Assets::generate_inline_css_global_classes())

However, this function is not available anymore and changed to \Bricks\Assets::generate_global_classes() since 1.8

You could reach their plugin support and feedback about this error to them.

Hope this helps.



Ok. I will contact Crocoblock support. Thanks.

1 Like

Hey there!

My topic was marked as a duplicate, but I had been reporting with two problems, not only this listing issue, but whatever, I’ll just duplicate the text on the filters issue here:

Filters problem:
When any filter is applied Bricks Query loop is sorted by some Custom Field value. And it does so- I only get posts that have necessary Custom Fields, but there are no images to any of them. At first I thought that the problem may be with the fact that I use Featured Images to display in the query loop and replaced them with another Custom Field with images in them, but it hasn’t worked out. It seems that by filtering the query loop it doesn’t update images in the said loop.

Video: Bricks/JF query bug - YouTube

Is it too an issue with Crocoblock, what do you think? Still waiting for them to respond.

The changes in Bricks 1.8/1.8.1 affect both the JE filters and the listings, and JetEngine has been informed about it. Sorry if I didn’t say that clearly enough in your thread.

Ah, ok then, thanks for claryfing. I will report here if I’ll get an update from them :).

I can report that they have no clue when it will be resolved… Now I can’t make planned switch from Elemntor to BricksBuilder.

You’re exactly right! This is what I’m seeing right now with their ‘Listing Grid’. I thought it was my custom query using their query builder… and bam, the error you listed.

I wonder how could they not catch this! I could understand if ALL of their plugins / addons worked with Bricks. But having only 2, I would think somebody would catch the fact that even if you put a totally empty Listing Grid on the page and just that alone broke the frontend, they should have noticed this immediately.

So, here is an update from Crocoblock support.

They have provided me with a next version of JE (3.1.7) that they plan to release soon and it seems that the issue with listings is gone. So I think it is possible to get your hands on it if you contact their support if you need these listings fixed ASAP.

Filters with featured images in Bricks Query:
The issue with featured images not updating when Bricks Query is filtered with JetSmartFilters, however, isn’t going to be fixed soon as I understand, as the Crocoblock support asked me if I really need to use this method of displaying featured images when I could just use their Dynamic Images widget. Well, its fine for me and Crocoblock doesn’t mention that they support Bricks with their SmartFilters plugin in full, but I think using workarounds isn’t a good thing towards making a plugin 100% compatible with Bricks.

A little bit of an off topic, but I have to mention their strange approach towards compatibility, to be honest. I don’t understand why the situation with the listings isn’t considered a critical one and how there was no hotfix instead of a regular bugfix update. I also don’t understand how they actually consider the JetEngine plugin to be Bricks-compatible when there is still no support for their charts and tables modules, despite no mentioning of lack of support for Bricks for these two modules on their website. I’m no dev to understand how to prioritize things in this field, but its still pretty disappointing, to be honest.

Thanks for the info. I’m using JE 3.2.0-beta2. Hope that it will be implemented in the final version. BTW, I’m stuck with Croco for now but would switch to something else in a heart bit if I can.

I’m not sure if this is the issue that you are facing, but if you are struggling with the images in a Bricks SQL query - try checking that the option to ‘Cast result to instance of object’ is set to POST. It’s hidden right at the end of the options …

As I understand, they have decided to skip 3.1.7 and release 3.2.1 publically straightaway with fixes from 3.1.7, so… I think the issue with listings can be considered solved. The only thing left now is that filter issue, but I don’t think that it’s going to be resolved quickly.