NO BUG: SVG Images work as intented, Logo element and Icons with custom SVG will not render and are not visible in DOM

Bricks Version: 1.6.1
Browser: Edge 108
OS: Windows
URL: (a link to a page that illustrates the issue would be really helpful)

Uploading SVG files work, but they suddenly won’t render either in the builder or in the front end. Everything is fine when using image elements. No code has been added to functions or elsewhere. Selecting custom icons will show on the sidebar, but the builder area will either keep showing the previous icon library icon or will remain empty if a custom icon was previously visible.

I know not everyone is having this issue, but hopefully something can be done…

Can you provide an example link where the issue is present? Rather hard to debug your build without it.

Unfortunately I can’t share the link, because Agency policy won’t allow public sharing, which sucks, I know.

What I can describe is that I have set up my own test environment on the same hosting provider and imported via WP All-In-One the exact same site. And for whatever reason the icon elements work there. The header itself is a simple one as well, just a block with a logo and a burger icon+text.

And the result on my project site just does not even generate a dom element for the custom SVG icons, site-wide. As soon as I use included icon fonts in the icon element or custom SVG-s with the image element, they work.

One thing that is different is that the project site is setup on a subfolder.

Both instances’ Bricks systems information and Wordpress site health system info are identical.

I am currently checking if there are any differences in the htaccess files that might create this issue.

And HTACCESS didn’t make a difference sadly. Weird af… Everything is identical.

I am running into the same exact issue. I uploaded svg icons to the media library, selected the icon element then svg. I am able to see the svg in the sidebar but it doesn’t render in the builder or the front end and is removed from the dom.

Any progress so far?

Hey Alo,
Sorry for the late reply and thanks so much for your report!

Unfortunately, I cannot reproduce the issue. Would you (or @sbaker - welcome to the forum :v:) be so kind as to send temporary login credentials and a link to this thread to using the email address you used during the purchase?

Best regards,

Hi @timmse, sure. The info is below

Credentials recorded in ticket
Jenn removed the credentials in this reply

I have the same issue on a client site! On my server everything works fine but on the client server all svgs are gone an in the backend i just get the blue choose svg thing… also on the client server the page is on a sub directory

Hi Federico, Welcome to the forum!
We’re currently investigating the issue :v:

I have the same problem at a current project when changing the domain. When changing the domain back it works again. Makes it impossible to launch the website right now.

@timmse have you already found anything on that? Our client makes pressure.


After changing the domain, have you tried using a Database Search & Replace tool like “Better Search Replace”?

I haven’t experienced this specific issue, but I have resolved many other weird issues by searching for the old domain and replacing it with the new domain.

** A word of caution though: Backup your Database first AND do a dry run to review the results and make sure it doesn’t replace anything you don’t want it to.

1 Like

Please try to search the database as Curtis suggested. Maybe the old value got stuck somewhere, which happens from time to time when moving with WordPress (also independent of Bricks).

I did do that.

The problem was that there were no real DNS records on the website domain but only an entry in the hosts file.

However, it’s still pretty strange that this is not working. But I suppose that the builder tries to fetch the svgs through their url to embed them into the page. But since the server doesn’t have the right records it doesn’t work.

I have exactly the same issue, SVG image works bot not logo or icon element even though it is visible in the left hand column, it doesn’t render in the DOM. Has any progress been made with this issue?

Welcome to the forum, and thanks for reaching out!

I just researched our email tickets: Alo’s problem had nothing to do with SVGs per se as far as I can see, however, we forgot to adjust the thread title.

In your case, is it just the SVG that is not displayed or other elements? Have you tried a different SVG from an additional source? Is it displayed in the frontend?

Best regards,

My issue is exactly as the title says. If I add the svg as an image it displays in the front end fine but if I add it as a logo element or icon it doesn’t display on the front end at all nor does any markup. I have added all three methods:

it is password protected: username: firthweb password: al765bd

Hey @lfirth,

I quickly stole your SVG for a test – sorry for that. :slight_smile: For me the SVG is shown when using an image element as well as a logo element (with no specific settings on each of them):

Would you be so kind as to send temporary login credentials and a link to this thread to using the email address you used during the purchase? Then I’m happy to have a look.