NO BUG: Query Loop not displaying dynamic fields from JetEngine CPT

Browser: Chrome 110
OS: macOS
URL: https://actiontroops.com/events/february-campout/?eid=1698
Video: Jam

In my event template, I have a Query Loop based on JetEngine related posts (Locations) for my Events CPT. In my Locations slider there are several fields per card…post_title, excerpt, featured_image, je_loc_contact_name, je_loc_contact_phone, je_loc_url, je_loc_address, etc. I can only get the Location title and excerpt to display properly. The featured image and all JE fields show as empty.

Hi Clinton,
Thanks so much for your report!

Unfortunately, I cannot reproduce the issue. Would you be so kind as to send temporary login credentials and a link to this thread to help@bricksbuilder.io using the email address you used during the purchase?

Best regards,
timmse

Hey Clinton,

as already mentioned by Jenn via mail, it looks like a recent JetEngine issue, as it works fine with JetEngine 3.3.1. Please reach out to the JetEngine support for further assistance.

Thanks for investigating! I found a similar report on GitHub that has been labeled as a bug by the Crocoblock team. Bug - Bricks (JetEngine) - Some Field (Image, Price) not working in Bricks JE Posts Query since 3.3.2 · Issue #7273 · Crocoblock/suggestions · GitHub

For now I have rolled back to JE 3.3.1 and everything appears to be working again.

2 Likes

This bug was confirmed by Crocoblock and has been addressed in the 3.4.0-Beta 2 version.

1 Like