NO BUG: Query Loop missing a post

Browser: Firefox latest
OS: Ubuntu
URL: NA without seeing backend
Video: Travis' Docs

A query loop that has existed for a while is not showing a new CPT post (Yelena) despite the post fitting the query filters. On a test page, I recreated the query loop with the same settings and the new CPT post shows up. I’ve tried turning the query loop on and off, changing the query loop filters, etc. and I can’t get the new CPT post to show up in the desired query loop / on the desired page.

Hi Sirhat,
Thanks so much for your report!

Could this possibly be a caching problem? If not, please send me access data via DM, then I can take a quick look.

Best regards,

I’m 99% sure it’s not caching, I’ve purged the page many times now, purged browser caching, etc. I could be wrong, caching can be fickle… but I don’t think so.

I have similar issue. An event from a custom cpt is not showing because infinite scroll is not working anymore in query loop. Therefore it only shows the 10 of the initial query. 1.7.1

Hey timmse, I DM’d you access credentials a few weeks ago. Any ideas here?

Hey Sirhat,
Sorry… the topic went a bit under… But we have it back on the radar :slight_smile:

Hey Sirhat,
We have found the problem. You had apparently inserted an order meta key (team_query_order) one day that was still present even after you switched to menu_order. Please make sure to reset the previously set settings to avoid issues.

CleanShot 2023-04-21 at 12.21.38

@Tobias Does your problem still exist? If so, please create a new report including information on how we can reproduce the problem.

Total doofus move there, wow…

Thank you for checking, and sorry about that :sweat_smile:

@timmse no I guess it was solved with 1.7.1.

1 Like

Hi guys,

We’ve added a check in Bricks 1.8 beta 3, now available as a manual download in your account, that should avoid this issue in the future.

Please let us know if you are still experiencing issues.

As with any beta release, please do not use it on any production/live website. It is only meant for testing in a local/staging environment.